Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007754 [DCSS] Upload: Maps and Vaults minor N/A 2013-11-17 04:10 2014-03-10 23:39
Reporter KennySheep View Status public  
Assigned To
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007754: various vaults
Description A Kikubaaqudgha overflow temple, several abstract vaults for the main dungeon, and a staircase-guarding vault for Dis.
Additional Information
Tags No tags attached.
Attached Files ? file icon more_vauts.des [^] (4,382 bytes) 2013-11-17 04:10 [Show Content]
? file icon more_vauts_v2.des [^] (4,293 bytes) 2013-11-17 05:24 [Show Content]
? file icon more_vaults_v3.des [^] (4,123 bytes) 2013-11-17 20:44 [Show Content]

- Relationships

-  Notes
(0024421)
Claws (developer)
2013-11-17 04:32

* Most of these DEPTH lines should be adjusted for the Depths branch stuff.
 * In most uses being able to use liquids as a guaranteed seperator wall is weak design, nullifying the tactical interests of monsters chasing players and allowing cheap tactics again and by several monsters. I recommend adding shallow water passages through _water_balloons, and using SHUFFLE tricks to avoid allowing the same results with _random_hallway

 * _vampire_church: An even small chance of extra sublimation of blood in the game (much less animate skeleton) are ridiculously generous gifts for a non-threat vault and an overflow altar vault, and there are an excess of altar vaults giving out books nowadays: I recommend just cutting the book. The blood fountains are also quite excessive for a rare feature with select large benefits for e.g. vampires, there should be just a chance for one and the rest can be dry fountains or empty foor or something.
 * _kite_vault: 45 statues in tiles is an eye-sore, and inconsistent glass diggability status is awkward: either make the random statue and glass placement very limited or avoid using it. Also, the DEPTHS: ...Vaults doesn't work with the Vaults tagging system, since the numbers are relatively high with little randomization it should use TAGS: vaults_hard.
 * kennysheep_cross_landing: the "all trees" potential result is potentially rather annoying due to (post-vault-clearing) potential of seeing but being unable to interact with a monster while getting autoexplore/rest/whatever complaints, some specific glyph adjustments would help a bunch.
 * _iron_temple: With a single exception that really ought to be fixed, no non-end vaults in the Hells branches have loot, and a vault that always takes up the floor stairs is pretty bad due to the spoilers of finding the vault and absolutely forcing people to do the vault. Remove the loot, NSUBST in one or two stairs at most while emphasizing a bit of exploration due to potentially getting an empty chamber, and it should be fine (give or take the staggering amount of variable difficult here)

Not inherently bad efforts or anything, just a bunch of tripping points and finer details to cover.
(0024423)
KennySheep (reporter)
2013-11-17 04:51
edited on: 2013-11-17 20:20

I assume you mean the harder vaults should be pushed down the dungeon to be depths only?

Water balloons already had shallow water paths, removing the no_pool_fixup tag from random_hallway to give it shallow paths too is simple enough.

The all trees version of cross_landing uses mangroves, you can't see through them.

What changes would you suggest to make iron_temple's difficulty a little more stable? I assume adding a no_monster_gen tag would be helpful.

Edit: Re-uploaded with most of Claw's suggestions implemented.

Also, kite_vault has been removed from being placed in vaults, for some reason trying to place it there for debug purposes always tries to place it over other vaults, it works fine in D though. I don't know if this is an error I made or a bug in Crawl.

Edit 2: I did not realize the depths was its own branch, I'll have that fixed soon.

(0024743)
KiloByte (manager)
2013-12-16 02:01

All but kennysheep_iron_temple are in. For some reason, it never succeeds to place -- I guess, it's a fault of Dis layouts rather than the vault itself.
(0025543)
sgrunt (administrator)
2014-03-10 20:59

iron_temple is now also in; it's tagged transparent and the stairs are SUBST:ed properly (mostly it was the former that caused it to not place, I assume).

Thus, we're done here.
(0025553)
KennySheep (reporter)
2014-03-10 23:39

Woot! Thank you!

- Issue History
Date Modified Username Field Change
2013-11-17 04:10 KennySheep New Issue
2013-11-17 04:10 KennySheep File Added: more_vauts.des
2013-11-17 04:32 Claws Note Added: 0024421
2013-11-17 04:51 KennySheep Note Added: 0024423
2013-11-17 05:24 KennySheep File Added: more_vauts_v2.des
2013-11-17 05:25 KennySheep Note Edited: 0024423
2013-11-17 05:27 KennySheep Note Edited: 0024423
2013-11-17 20:20 KennySheep Note Edited: 0024423
2013-11-17 20:44 KennySheep File Added: more_vaults_v3.des
2013-12-16 02:01 KiloByte Note Added: 0024743
2014-03-10 20:59 sgrunt Note Added: 0025543
2014-03-10 20:59 sgrunt Status new => resolved
2014-03-10 20:59 sgrunt Resolution open => done
2014-03-10 20:59 sgrunt Fixed in Branch => 0.14 development branch
2014-03-10 23:39 KennySheep Note Added: 0025553


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker