Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007750 [DCSS] Patches trivial have not tried 2013-11-16 10:10 2014-12-21 09:41
Reporter chris View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.14 ancient branch
Summary 0007750: Use `spectral mon` instead of `mon spectre`
Description These were the last remaining spectres. No functional change (none intended, at least).
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Use-spectral-mon-instead-of-mon-spectre.patch [^] (2,896 bytes) 2013-11-16 10:10 [Show Content]

- Relationships

-  Notes
(0024415)
KiloByte (manager)
2013-11-16 18:02

I quite don't get the point of changing vaults but not the underlying code, especially if the reason you state is an issue with the code rather than vaults.
(0024419)
chris (updater)
2013-11-16 20:05

Mostly intended for folks who look up how things are done elsewhere when making own vaults I guess. Having a consistent interface would be cool as well, but that's a different task and one I won't tackle myself.
Feel free to split off the related syntax file change if that one bothers you. While I'll admit that was what triggered the patch, but fixing that glitch isn't really the point here :)
(0024433)
neil (administrator)
2013-11-18 18:42
edited on: 2013-11-18 18:45

It looks like it would make the C++ side a little more complicated to remove the ability to use "foo spectre". And "place:Depths:2 spectre" reads a little better than "spectral place:Depths:2" (likewise "any spectre" vs "spectral any"). So I am applying the patch (0.14-a0-937-gdb87d43) but leaving this issue open. I also replaced one occurrence in a spell description, which I squashed into the same commit.

(0027328)
wheals (administrator)
2014-09-21 04:05

I don't see much reason to forbid the use of `foo spectre` if it makes the code more complicated; the ability can just be undocumented. At any rate, no longer a patch, and probably not critical enough to keep on Mantis.

- Issue History
Date Modified Username Field Change
2013-11-16 10:10 chris New Issue
2013-11-16 10:10 chris File Added: 0001-Use-spectral-mon-instead-of-mon-spectre.patch
2013-11-16 18:02 KiloByte Note Added: 0024415
2013-11-16 20:05 chris Note Added: 0024419
2013-11-18 18:42 neil Note Added: 0024433
2013-11-18 18:43 neil Note Edited: 0024433
2013-11-18 18:45 neil Note Edited: 0024433
2013-11-18 18:45 neil Status new => confirmed
2014-09-21 04:05 wheals Note Added: 0027328
2014-09-21 04:05 wheals Status confirmed => resolved
2014-09-21 04:05 wheals Fixed in Branch => 0.16 development branch
2014-09-21 04:05 wheals Resolution open => done
2014-09-21 04:05 wheals Assigned To => wheals
2014-12-21 09:41 chris Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker