Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007743 [DCSS] Upload: Maps and Vaults minor N/A 2013-11-13 04:25 2014-03-10 23:50
Reporter KennySheep View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007743: A sewer layout
Description A temple to Makhleb built in the sewers. Featuring puny demons, kobolds and zombies. The map ends with 3 runed doors leading to chambers with loot and a boss. At best the boss can be a big kobold, at worst it's Grinder.

The only bit of this map I think may be problematic is the kobold demonologists, which I've edited to only have the summon minor demon spell. If messing with monster's abilities like that isn't something I should have done they can easily be removed.
Additional Information
Tags No tags attached.
Attached Files ? file icon sewer_demons.des [^] (3,116 bytes) 2013-11-13 04:25 [Show Content]
? file icon sewer_demons_v2.des [^] (3,132 bytes) 2013-11-14 03:45 [Show Content]
? file icon sewer_demons_v3.des [^] (3,180 bytes) 2013-11-25 19:49 [Show Content]

- Relationships

-  Notes
(0024408)
KennySheep (reporter)
2013-11-14 03:50
edited on: 2013-11-14 03:55

I've uploaded a v2 with a few small changes. Water tiles now have no_tele_into tags on them to prevent random ports onto the tiny unreachable shallow sections it sometimes spawns. Potions of restore ability have been added to the loot to balance out needing to possibly fight an out of depth quasit. Quasits have been removed from the list of placed monsters to remove the small but real chance of fighting two quasits + grinder at the end. Demonologists' spellsets have been given far more cantrip. There are slightly less fish now.

(0024460)
dpeg (administrator)
2013-11-23 01:39

I think it's okay! Grinder looks harsh, but his natural depth is D:3-6 -- exactly the range of Sewers. And getting an early portal vault generally means that the character is at least an XL ahead of the normal curve.

If this turns out to be too bad, we can make sure that the player sees the final threat before opening the door.

I believe that modifying the kobold demonologists' spell set is fine, but should be reflected in their name (give them some adjective, for example).
(0024497)
KennySheep (reporter)
2013-11-25 19:50

%%%%
apprentice kobold demonologist

A kobold who is in league with demonic powers. It can call forth beings from
the depths of Hell, but has not yet mastered the skill well enough to command
anything but the most minor of demons.
(0025554)
sgrunt (administrator)
2014-03-10 23:50

This is in, with some changes.

- Issue History
Date Modified Username Field Change
2013-11-13 04:25 KennySheep New Issue
2013-11-13 04:25 KennySheep File Added: sewer_demons.des
2013-11-14 03:45 KennySheep File Added: sewer_demons_v2.des
2013-11-14 03:50 KennySheep Note Added: 0024408
2013-11-14 03:55 KennySheep Note Edited: 0024408
2013-11-23 01:39 dpeg Note Added: 0024460
2013-11-25 19:49 KennySheep File Added: sewer_demons_v3.des
2013-11-25 19:50 KennySheep Note Added: 0024497
2014-03-10 23:50 sgrunt Note Added: 0025554
2014-03-10 23:50 sgrunt Assigned To => sgrunt
2014-03-10 23:50 sgrunt Status new => resolved
2014-03-10 23:50 sgrunt Resolution open => done
2014-03-10 23:50 sgrunt Fixed in Branch => 0.14 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker