Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007733 [DCSS] Bug Report trivial always 2013-11-11 04:51 2013-11-17 04:38
Reporter Wahaha View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007733: Resistance from scales mutation not shown on character sheet.
Description When a demonspawn gets scales with a resist, for example molten or icy scales, the 'A' mutations screen properly shows that the scales give a resistance. However, the '%' character sheet mutations section doesn't show the resistance. This is probably the case with scales obtained from other mutation sources too.
Additional Information
Tags No tags attached.
Attached Files png file icon scales.PNG [^] (39,390 bytes) 2013-11-11 04:51


? file icon 0001-Briefly-mention-scales-resistance-effects-in-screen-.patch [^] (2,208 bytes) 2013-11-16 12:10 [Show Content]

- Relationships

-  Notes
(0024411)
chris (updater)
2013-11-16 12:14

Resistances are shown in the resistance section, so I don't particularly see a need to repeat that in `A`. Oh wait, this screen is just a mess? Fine then...

You'll see the AC bonuses from all mutations grouped together as one number there for instance, and even tracking that is some ugly code already. It happens for [AC EV SH Str Int Dex]. It is godawful.

Of course all that is weak arguments, so here's a patch adding some short hints to the overview even if they are confusing - e.g. displaying "rF+" in the mutation list, which looks like a summary much like the others mentioned above, when in reality you also wear a ring of ice.
Does not take into account the separate rF/rC/... mutations.
(0024420)
MarvinPA (developer)
2013-11-17 03:36

Maybe that "A: " list on the % screen should just list mutation names and levels for scales, instead of duplicating a ton of stuff that inevitably gets out of sync with mutation changes. The full info is still right there on the A screen.
(0024422)
MarvinPA (developer)
2013-11-17 04:38

^ I did that thing.

- Issue History
Date Modified Username Field Change
2013-11-11 04:51 Wahaha New Issue
2013-11-11 04:51 Wahaha File Added: scales.PNG
2013-11-16 12:10 chris File Added: 0001-Briefly-mention-scales-resistance-effects-in-screen-.patch
2013-11-16 12:14 chris Note Added: 0024411
2013-11-17 03:36 MarvinPA Note Added: 0024420
2013-11-17 04:38 MarvinPA Note Added: 0024422
2013-11-17 04:38 MarvinPA Status new => resolved
2013-11-17 04:38 MarvinPA Fixed in Branch => 0.14 development branch
2013-11-17 04:38 MarvinPA Resolution open => done
2013-11-17 04:38 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker