Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007726 [DCSS] Bug Report trivial always 2013-11-09 22:02 2014-08-01 00:22
Reporter dck View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007726: Zin doesn't care about butchering Xtahua.
Description Which is kinda strange because xtahua has normal intelligence, speaks and can open doors.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024350)
neil (administrator)
2013-11-09 22:15

Kind of tough to fix, because the corpse is just a fire dragon corpse with a name. Likewise with Gastronok. The same problem occurs when an intelligent being (particularly a unique) was polymorphed into a normally unintelligent form.

We could complain about butchering a corpse with a name, but the Lernaean hydra has a name and is nonethless unintelligent. And if the monster is exploded into chunks (IOOD, disintegration), we don't even have a name to go by.
(0025804)
tedric (reporter)
2014-04-07 21:29

I was about to add a bug report for the same thing re: Gastronok in trunk (currently .15 development branch). From neil's note it sounds like it's a known issue but a low priority and might take more effort than it's worth -- just a bump to say that at least one other player has noticed and wondered about this odd inconsistency.
(0026876)
neil (administrator)
2014-08-01 00:22
edited on: 2014-08-01 00:23

Fixed in trunk (0.15-a0-2375-gba7f006). It turns out we actually did store the necessary information. Now Zin will consider the intelligence of the original monster rather than its species.

There are some oddities about merging these forbidden stacks with other stacks of chunks of the same species; and names still aren't actually displayed on chunks, only on corpses.


- Issue History
Date Modified Username Field Change
2013-11-09 22:02 dck New Issue
2013-11-09 22:15 neil Note Added: 0024350
2014-04-07 21:29 tedric Note Added: 0025804
2014-08-01 00:22 neil Note Added: 0026876
2014-08-01 00:22 neil Status new => resolved
2014-08-01 00:22 neil Fixed in Branch => 0.15 development branch
2014-08-01 00:22 neil Resolution open => done
2014-08-01 00:22 neil Assigned To => neil
2014-08-01 00:23 neil Note Edited: 0026876


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker