Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007710 [DCSS] Upload: Maps and Vaults feature N/A 2013-11-07 00:02 2013-11-08 16:49
Reporter Claws View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007710: Lair branch end vault edits
Description Long set of notes in the commit message. Highlights of those highlights:

 * Extremes of min/max spawns in many ends cut off, force a (lower) average. Thus effected: "swamp", "snake_pit", minmay_snake_end_coiled, snake_pit_salamanders_mu, grunt_spider_rune_parallel, grunt_spider_rune_island
 * 1/11 chance of the Lernaean Hydra in most of the swamp ends.
 * Buffed: swamp_alternative, swamp_fiery, "snake_pit", minmay_snake_end_coiled
 * Nerfed: snake_pit_salamanders_mu, (randomly) Ilsuiw's hut.
 * swamp_pestilence has small, fast miasma generators instead of one big always-present blockade, unreliable for escape still but no forcing rot.
 * grunt_snake_rune_pools no longer uses glass, also lost some doors.
 * grunt_spider_rune_parallel is restructured to make more use of the extra numbers and size it has over most rune vaults.
 * Pre-identify _extra_ webs in Spider ends, reduce open-floor shallow water.
Additional Information
Tags No tags attached.
Attached Files ? file icon Snake-Swamp-Shoals-Spider-branch-end-vault-edits.patch [^] (57,223 bytes) 2013-11-07 00:02 [Show Content]
? file icon 1-Swamp-end-edits.patch [^] (20,663 bytes) 2013-11-07 04:48 [Show Content]
? file icon 2-Snake-end-edits.patch [^] (16,928 bytes) 2013-11-07 04:48 [Show Content]
? file icon 3-Spider-end-edits.patch [^] (16,567 bytes) 2013-11-07 04:48 [Show Content]
? file icon 4-Shoals-end-edits.patch [^] (3,392 bytes) 2013-11-07 04:48 [Show Content]

- Relationships

-  Notes
(0024315)
Claws (developer)
2013-11-07 04:50

Split the patches into four separate files, as per ##crawl-dev request.
(0024316)
SamB (developer)
2013-11-07 06:43

It turns out that having lines that start with a word followed by a colon (i.e., "Highlights:") causes bad things to happen to your commit messages at "git am" time :-(.
(0024328)
MarvinPA (developer)
2013-11-08 16:49

These were applied.

- Issue History
Date Modified Username Field Change
2013-11-07 00:02 Claws New Issue
2013-11-07 00:02 Claws File Added: Snake-Swamp-Shoals-Spider-branch-end-vault-edits.patch
2013-11-07 04:48 Claws File Added: 1-Swamp-end-edits.patch
2013-11-07 04:48 Claws File Added: 2-Snake-end-edits.patch
2013-11-07 04:48 Claws File Added: 3-Spider-end-edits.patch
2013-11-07 04:48 Claws File Added: 4-Shoals-end-edits.patch
2013-11-07 04:50 Claws Note Added: 0024315
2013-11-07 06:43 SamB Note Added: 0024316
2013-11-08 16:49 MarvinPA Note Added: 0024328
2013-11-08 16:49 MarvinPA Status new => resolved
2013-11-08 16:49 MarvinPA Fixed in Branch => 0.14 development branch
2013-11-08 16:49 MarvinPA Resolution open => done
2013-11-08 16:49 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker