Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007680 [DCSS] Bug Report minor unable to reproduce 2013-10-29 18:51 2014-05-19 18:51
Reporter Skrybe View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.13 ancient branch
Summary 0007680: Unknown shafts don't trigger, give "You can't go down here!" message.
Description xom_obstacle_run generated in a recent game, and there's a certain square where every time the character steps on it, the game gives a "You can't go down here!" message, like I'm pushing > when not on stairs. I'm guessing it's related to the shaft trap that's supposed to generate. The tile in question is the one immediately south of the needle trap in the save. Save is from stable 0.13.0, but testing it in 0.13.0-11-g0187522 had the same effect. I wasn't able to reproduce this in a couple attempts in wizard mode.
Additional Information
Tags No tags attached.
Attached Files ? file icon Lugalirra.cs [^] (124,306 bytes) 2013-10-29 18:51

- Relationships

-  Notes
(0024277)
galehar (administrator)
2013-10-31 17:24

Seems like an undiscovered shaft trap. I had the same in wizmode, although I haven't been able to find the bug (maybe related to 83f22819?)
(0024291)
MarvinPA (developer)
2013-11-02 13:33

It seems to be _check_stairs() in stairs.cc that's causing this to happen? I'm not quite sure how or why though, it doesn't look like it should be doing anything when being shafted.
(0024299)
neil (administrator)
2013-11-03 18:54

Fixed in trunk (0.14-a0-594-g0ab4eda) and stable (0.13.0-29-gdb529de), thanks!

- Issue History
Date Modified Username Field Change
2013-10-29 18:51 Skrybe New Issue
2013-10-29 18:51 Skrybe File Added: Lugalirra.cs
2013-10-31 17:24 galehar Note Added: 0024277
2013-11-02 13:31 MarvinPA Summary xom_obstacle_run gives "You can't go down here!" message. => Unknown shafts don't trigger, give "You can't go down here!" message.
2013-11-02 13:33 MarvinPA Note Added: 0024291
2013-11-03 18:54 neil Note Added: 0024299
2013-11-03 18:54 neil Status new => resolved
2013-11-03 18:54 neil Fixed in Branch => 0.13 stable branch
2013-11-03 18:54 neil Resolution open => done
2013-11-03 18:54 neil Assigned To => neil
2014-05-19 18:51 Skrybe Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker