Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007637 [DCSS] Bug Report crash have not tried 2013-10-16 18:08 2013-12-01 21:32
Reporter flun View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007637: Annotating a level crashes game
Description If I press '!' on a level the game crashes. There is a previous annotation on the level already if that makes a difference.

<Sequell> 9. [2013-10-16 16:00:30] [v=0.13.0] Flun the Grappler (L14 TrCK) ERROR in 'libutil.cc' at line 1020: screen write out of bounds: (1,8) into (80,7) (Lair:3)

Seems to be a similar problem to the one in this thread:
https://crawl.develz.org/tavern/viewtopic.php?f=9&t=9429 [^]

Save backup:
http://dobrazupa.org/saves/Flun-crash-20131016.cs [^]

My config file:
http://dobrazupa.org/rcfiles/crawl-0.13/Flun.rc [^]
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024569)
neil (administrator)
2013-12-01 21:32

This should be fixed in trunk now (0.14-a0-1234-g31edfb4), though I can't reproduce the crash.

- Issue History
Date Modified Username Field Change
2013-10-16 18:08 flun New Issue
2013-12-01 21:32 neil Note Added: 0024569
2013-12-01 21:32 neil Status new => resolved
2013-12-01 21:32 neil Fixed in Branch => 0.14 development branch
2013-12-01 21:32 neil Resolution open => done
2013-12-01 21:32 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker