Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007612 [DCSS] Bug Report minor always 2013-10-06 20:26 2013-10-06 20:59
Reporter CommanderC View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007612: Non-summoned monsters are abjured when their leader is killed.
Description I killed an orc knight and all his band was abjured. Commit bf86b442 should have a "&& mons->has_ench(ENCH_SUMMON)" in the first if.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024168)
neil (administrator)
2013-10-06 20:59

Fixed in trunk (0.14-a0-197-g87bc352), thanks! I checked for ENCH_ABJ rather than ENCH_SUMMON because the latter might be missing in some cases. I also had it use del_ench rather than remove_enchantment_effect

- Issue History
Date Modified Username Field Change
2013-10-06 20:26 CommanderC New Issue
2013-10-06 20:43 neil Status new => assigned
2013-10-06 20:43 neil Assigned To => neil
2013-10-06 20:59 neil Note Added: 0024168
2013-10-06 20:59 neil Status assigned => resolved
2013-10-06 20:59 neil Fixed in Branch => 0.14 development branch
2013-10-06 20:59 neil Resolution open => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker