Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007609 [DCSS] Bug Report minor always 2013-10-06 01:25 2014-12-04 21:16
Reporter pubby View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007609: mondied always false in art-func.h
Description A few unrands check the mondied parameter in their melee_effect functions, despite the value always being false.

The only unrand that mondied works correctly for is Wyrmbane. This is because it was special-cased in melee_attack.cc
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0027975)
PleasingFungus (administrator)
2014-12-04 21:16

This was fixed in 84f1c15 (and f66a7a853).

- Issue History
Date Modified Username Field Change
2013-10-06 01:25 pubby New Issue
2014-12-04 21:16 PleasingFungus Note Added: 0027975
2014-12-04 21:16 PleasingFungus Status new => resolved
2014-12-04 21:16 PleasingFungus Fixed in Branch => 0.16 development branch
2014-12-04 21:16 PleasingFungus Resolution open => done
2014-12-04 21:16 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker