Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007607 [DCSS] Bug Report minor N/A 2013-10-05 21:54 2013-10-05 22:04
Reporter pubby View Status public  
Assigned To KiloByte
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0007607: Fix in you_can_wear for macabre finger necklace
Description The amulet check wasn't happening if you were an octopode or felid.

Definitely looks like a mistake, but I didn't notice any problems from it. Here's a patch to fix.
Additional Information
Tags No tags attached.
Attached Files ? file icon macabre_fix.patch [^] (1,414 bytes) 2013-10-05 21:54 [Show Content]

- Relationships

-  Notes
(0024161)
KiloByte (manager)
2013-10-05 22:04

Applied.

I just reordered the checks, though: an unlikely check on a local variable is better done before costly player_equip_unrand() that has to check suppression and what not.

- Issue History
Date Modified Username Field Change
2013-10-05 21:54 pubby New Issue
2013-10-05 21:54 pubby File Added: macabre_fix.patch
2013-10-05 22:04 KiloByte Note Added: 0024161
2013-10-05 22:04 KiloByte Status new => resolved
2013-10-05 22:04 KiloByte Fixed in Branch => 0.14 development branch
2013-10-05 22:04 KiloByte Resolution open => done
2013-10-05 22:04 KiloByte Assigned To => KiloByte


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker