Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007584 [DCSS] Bug Report minor sometimes 2013-09-29 20:57 2014-06-01 06:01
Reporter neil View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.6 ancient branch
Summary 0007584: set_border_fill_type doesn't randomize properly
Description Because the border fill is stored as part of the map index, it is computed once and index-building time and not updated later. Several maps, such as minmay_temple_bridge_*, try to do both set_border_fill_type and subst inside the same conditional, but since the index-time border fill is not reset when initialising the map lines, they no longer sync up.

The result is that, in a given install of crawl, each of these maps will have the same border (endless_lava or open_sea) whenever it is generated, even if the map itself doesn't match.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024171)
neil (administrator)
2013-10-06 22:13

Fixed in trunk (0.14-a0-202-g3afabac) and beta (0.13-b1-33-g94b2e5f).

- Issue History
Date Modified Username Field Change
2013-09-29 20:57 neil New Issue
2013-10-06 22:13 neil Note Added: 0024171
2013-10-06 22:13 neil Status new => resolved
2013-10-06 22:13 neil Fixed in Branch => 0.13 pre-release branch
2013-10-06 22:13 neil Resolution open => done
2013-10-06 22:13 neil Assigned To => neil
2014-06-01 06:01 neil Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker