Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007576 [DCSS] Bug Report minor have not tried 2013-09-25 21:08 2013-09-27 17:19
Reporter jeanjacques View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.16 ancient branch
Summary 0007576: wand of random effects should not be marked evil_item under tso
Description The random bolt of draining only causes:

The Shining One forgives your inadvertent unholy act, just this once.

The wand is very useable under TSO and should not be marked useless/evil like wands of draining.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024089)
MarvinPA (developer)
2013-09-25 21:15

Alternatively he should actually punish you if you get draining, once you've identified the wand as random effects.
(0024090)
sgrunt (administrator)
2013-09-25 21:25

MarvinPA's suggestion seems to me to be the intended behaviour here.
(0024096)
BlackSheep (reporter)
2013-09-26 18:29

The beam code handles the conducts, and zap_wand() sets beam.effect_known = false for wands of random effects. This prevents warning messages from beams that might hit the player, but is also used in the call to did_god_conduct(), so the conduct is never "known".
(0024100)
neil (administrator)
2013-09-27 16:28
edited on: 2013-09-27 16:32

Fixed in trunk (0.14-a0-32-gdbef0e0). I applied MarvinPA's suggestion: I added a separate beam.effect_wanton and set that when the source was known random effects. The god checks all use that now (more specifically, bolt::god_cares(), which returns effect_known || effect_wanton). The same applies to chaos melee (which is always known and therefore always wanton) and chaos launchers (wanton if the launcher is chaos, or if the ammunition is known chaos).

(0024103)
KiloByte (manager)
2013-09-27 17:19

"known" chaos? Is there any other kind? Missiles are always known.

- Issue History
Date Modified Username Field Change
2013-09-25 21:08 jeanjacques New Issue
2013-09-25 21:15 MarvinPA Note Added: 0024089
2013-09-25 21:25 sgrunt Note Added: 0024090
2013-09-26 18:29 BlackSheep Note Added: 0024096
2013-09-27 16:28 neil Note Added: 0024100
2013-09-27 16:28 neil Status new => resolved
2013-09-27 16:28 neil Fixed in Branch => 0.13 development branch
2013-09-27 16:28 neil Resolution open => done
2013-09-27 16:28 neil Assigned To => neil
2013-09-27 16:32 neil Note Edited: 0024100
2013-09-27 17:19 KiloByte Note Added: 0024103


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker