Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007559 [DCSS] Bug Report minor always 2013-09-17 04:58 2013-09-17 17:46
Reporter G-Flex View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007559: Mute creatures still vocalize their flavor text
Description Creatures muted by Recite (and probably any other source of mute, if there is one) will still say things.

The example I'm seeing in particular right now is a mute orc high priest, but I know it's happened with others:

"The orc high priest shouts, "Join the one true god or die!""

Pretty self-explanatory.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Fix-mute-monsters-speaking-7559.patch [^] (902 bytes) 2013-09-17 06:39 [Show Content]

- Relationships

-  Notes
(0024029)
Reaver (developer)
2013-09-17 06:28
edited on: 2013-09-17 06:40

I wrote a simple patch. I didn't get a chance to test it properly because it's late where I am. The first and second files where uploaded by mistake, they don't work. Use the third one. (There really should be a way to delete files you uploaded...)

(0024031)
Galefury (updater)
2013-09-17 10:34
edited on: 2013-09-17 17:12

Sure it would be good if everyone could delete their own files. But since you cant, just ask galehar or Napkin for updater status, then you can delete all files.

(0024042)
neil (administrator)
2013-09-17 17:46

Fixed in trunk (0.13-a0-3080-g98ea790), thanks! I had to adjust reaver's patch to move the check earlier so that it would correctly influence the first iteration of the loop. I also added an additional check in mons_allows_beogh_now so you won't get the status light either.

- Issue History
Date Modified Username Field Change
2013-09-17 04:58 G-Flex New Issue
2013-09-17 06:27 Reaver File Added: Fix-mute-monsters-talking-7559.patch
2013-09-17 06:28 Reaver Note Added: 0024029
2013-09-17 06:29 Reaver Note Edited: 0024029
2013-09-17 06:36 Reaver File Added: Correct_fix_mute_monsters_speaking.patch
2013-09-17 06:37 Reaver Note Edited: 0024029
2013-09-17 06:38 Reaver Note Edited: 0024029
2013-09-17 06:39 Reaver File Added: 0001-Fix-mute-monsters-speaking-7559.patch
2013-09-17 06:40 Reaver Note Edited: 0024029
2013-09-17 10:31 Galefury File Deleted: Fix-mute-monsters-talking-7559.patch
2013-09-17 10:31 Galefury File Deleted: Correct_fix_mute_monsters_speaking.patch
2013-09-17 10:34 Galefury Note Added: 0024031
2013-09-17 17:12 Galefury Note Edited: 0024031
2013-09-17 17:46 neil Note Added: 0024042
2013-09-17 17:46 neil Status new => resolved
2013-09-17 17:46 neil Fixed in Branch => 0.13 development branch
2013-09-17 17:46 neil Resolution open => done
2013-09-17 17:46 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker