Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007536 [DCSS] Bug Report minor have not tried 2013-09-05 06:47 2013-11-02 06:01
Reporter sim View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007536: Possible to get multiple spectral weapons by taking stairs
Description spectral weapon has a couple of odd behaviors ive found.

first, you can get a second (or potentially more) copy by casting spectral weapon and changing floors when it's not next to you. re-cast the spell it will create a second copy. you can return to the previous floor and have two at the same time.

second, bringing a spectral weapon down a floor has an issue too. the spectral weapon typically wont sit next to you, but instead "run away" to your los or even just disappear from sight completely. it wont come back when you hit things, so you have to resummon for the ai to function again.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Prevent-copies-of-spectral-weapons.patch [^] (824 bytes) 2013-11-02 05:37 [Show Content]

- Relationships
related to 0007521resolvedneil Battlesphere dissipates after walking stairs 
related to 0009713new Possible to get multiple spectral weapons 

-  Notes
(0024229)
morik (reporter)
2013-10-22 05:49

I've seen the 2nd behavior in my game.
(0024281)
neil (administrator)
2013-11-01 08:00

The second behaviour is fixed in trunk (0.14-a0-520-g79a0f27) and stable (0.13.0-27-gc65393c), thanks! It turns out that changing levels made monsters forget who summoned them, so the SW didn't know where to set its target position. It therefore headed to (0,0).

It still seems to be possible to get two SWs, so I am not closing this bug.
(0024288)
Naruni (reporter)
2013-11-02 05:38

The spectral weapon will still follow you down stairs. If it gets left behind, it poofs away.
(0024289)
neil (administrator)
2013-11-02 06:01

Naruni's patch for the first behaviour is in trunk (0.14-a0-553-g3dc45ab) and stable (0.13.0-28-g1b50097), thanks!

- Issue History
Date Modified Username Field Change
2013-09-05 06:47 sim New Issue
2013-10-22 05:49 morik Note Added: 0024229
2013-11-01 07:50 neil Relationship added related to 0007521
2013-11-01 08:00 neil Note Added: 0024281
2013-11-01 08:01 neil Summary spectral weapon oddities => Possible to get multiple spectral weapons by taking stairs
2013-11-02 05:37 Naruni File Added: 0001-Prevent-copies-of-spectral-weapons.patch
2013-11-02 05:38 Naruni Note Added: 0024288
2013-11-02 06:01 neil Note Added: 0024289
2013-11-02 06:01 neil Status new => resolved
2013-11-02 06:01 neil Fixed in Branch => 0.13 stable branch
2013-11-02 06:01 neil Resolution open => done
2013-11-02 06:01 neil Assigned To => neil
2015-05-10 14:07 neil Relationship added related to 0009713


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker