Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007527 [DCSS] Bug Report major always 2013-09-01 01:11 2015-04-11 07:22
Reporter gammafunk View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status closed   Product Branch 0.13 ancient branch
Summary 0007527: Some forest vaults fail to place consistently
Description I had noticed that I've never seen any of my forest vaults on either CSZO or CAO that weren't the forest end despite observing many players clear forest. It seems that certain maps have a very hard time placing, others less so, and some place all the time. Here are some results for attempting to generate my forest maps (excluding the end) on forest:1. I got these by setting the vault's chance to 100% and using & ctrl-R to regenerate the level 20 times, checking to see if the vault placed.

gammafunk_forest_sporulate: placed 20/20 times
gammafunk_forest_bear_cave: placed 13/20
gammafunk_forest_yreds_foothold: placed 1/20
gammafunk_forest_enchanted_lake: placed 0/20

For the two that fail almost all the time (foothold, lake), the problem seems to be just placement. When the bear cave fails to generate, sometimes it fails to place, but at other times it places eventually and then gets vetoed due to multiple zones. In the attach failure example for the cave, vetoing happened multiple rounds before the vault simply failed to place on the last round.

I think yreds_foothold could stand to lose the entrance @ connectors for sections that never lead to the central chapel, which may help the problem. But it seems that some vault designs are problematic with the forest layout. The enchanted forest has only the two connectors, although it is the only non-float layout. Testing with &P showed no problems with any of these during their development.
Additional Information
Tags No tags attached.
Attached Files txt file icon enchanted_lake_fail.txt [^] (4,993 bytes) 2013-09-01 01:11 [Show Content]
txt file icon foothold_fail.txt [^] (6,646 bytes) 2013-09-01 01:12 [Show Content]
txt file icon bear_cave_fail.txt [^] (17,971 bytes) 2013-09-01 01:13 [Show Content]

- Relationships

-  Notes
(0026124)
gammafunk (administrator)
2014-05-10 19:39

Forest has been removed, a couple important vault placement bugs have been fixed, and my forest vaults have been relocated, so this is no longer an issue.

- Issue History
Date Modified Username Field Change
2013-09-01 01:11 gammafunk New Issue
2013-09-01 01:11 gammafunk File Added: enchanted_lake_fail.txt
2013-09-01 01:12 gammafunk File Added: foothold_fail.txt
2013-09-01 01:13 gammafunk File Added: bear_cave_fail.txt
2014-05-10 19:39 gammafunk Note Added: 0026124
2014-05-10 19:39 gammafunk Status new => resolved
2014-05-10 19:39 gammafunk Fixed in Branch => 0.15 development branch
2014-05-10 19:39 gammafunk Resolution open => done
2014-05-10 19:39 gammafunk Assigned To => gammafunk
2015-04-11 07:22 gammafunk Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker