Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007521 [DCSS] Bug Report minor always 2013-08-29 17:36 2013-11-01 08:01
Reporter Ladykiller69 View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007521: Battlesphere dissipates after walking stairs
Description If you summon a battlesphere and then walk up the stairs with it it will dissipate much sooner than it would otherwise have.
Additional Information
Tags No tags attached.
Attached Files txt file icon p.txt [^] (5,693 bytes) 2013-08-29 23:29 [Show Content]

- Relationships
related to 0007536resolvedneil Possible to get multiple spectral weapons by taking stairs 

-  Notes
(0023928)
Ladykiller69 (reporter)
2013-08-29 17:40

After further playing it seems to not in fact be always happening but quite frequent.
(0023929)
BlackSheep (reporter)
2013-08-29 19:05

If you leave the floor without your battlesphere, it will immediately dissipate.
(0023931)
Ladykiller69 (reporter)
2013-08-29 21:07

What I described occurs if it comes with you to the next floor.
(0023933)
Naruni (reporter)
2013-08-29 23:29

I think this is confirmed...

Added this line to spl-summoning.cc:
mprf("Current duration is: %u", battlesphere->get_ench(ENCH_FAKE_ABJURATION).duration);

And numerous times after recharging the sphere, it will disappear after climbing/descending stairs while there was enough time to hang around.

I attached the log file from the game.
(0024263)
Hurkyl (reporter)
2013-10-28 22:56

Furthermore, if you cast battlesphere as your first action downstairs, the effect is to recharge the battlesphere... and then it still immediately suicides.
(0024282)
neil (administrator)
2013-11-01 08:01

Fixed in trunk (0.14-a0-520-g79a0f27) and stable (0.13.0-27-gc65393c), thanks! It turns out that changing levels made monsters forget who summoned them, and battlespheres dissipate on their turn if they don't have a live summoner.

- Issue History
Date Modified Username Field Change
2013-08-29 17:36 Ladykiller69 New Issue
2013-08-29 17:40 Ladykiller69 Note Added: 0023928
2013-08-29 19:05 BlackSheep Note Added: 0023929
2013-08-29 21:07 Ladykiller69 Note Added: 0023931
2013-08-29 23:29 Naruni Note Added: 0023933
2013-08-29 23:29 Naruni File Added: p.txt
2013-10-28 22:56 Hurkyl Note Added: 0024263
2013-11-01 07:50 neil Relationship added related to 0007536
2013-11-01 08:01 neil Note Added: 0024282
2013-11-01 08:01 neil Status new => resolved
2013-11-01 08:01 neil Fixed in Branch => 0.13 stable branch
2013-11-01 08:01 neil Resolution open => done
2013-11-01 08:01 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker