Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007514 [DCSS] Bug Report crash always 2013-08-26 04:14 2013-08-26 05:02
Reporter tmhedberg View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007514: Crash when examining player ghost with `xv`
Description `xv` on a player ghost causes the game to crash with an assertion failure:

ERROR in 'spl-util.cc' at line 894: ASSERT failed: spell of 11705923 out of range 0 (0) .. NUM_
SPELLS (261)


I assume this has something to do with the spellbook display that was recently added to that screen in trunk.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0023871)
Grandiloquent Gentleman (reporter)
2013-08-26 04:31

I think this just got fixed (9c95cb4).
(0023872)
tmhedberg (reporter)
2013-08-26 04:42

I was using a version (0b72a8e) which includes that commit when I saw the crash.

However, after trying it out some more, I can't seem to reproduce it again, so maybe it was just a fluke. Strange, since it crashed on two separate player ghosts I encountered on the same level.
(0023873)
neil (administrator)
2013-08-26 05:02
edited on: 2013-08-26 05:28

Fixed in trunk (0.13-a0-2816-gd8154f0), thanks! It also affected player illusions and random pan lords.

Even when it didn't crash (that depends on the contents of uninitialised memory) it would give incorrect spell lists (I saw "Death Channel" in my local build).


- Issue History
Date Modified Username Field Change
2013-08-26 04:14 tmhedberg New Issue
2013-08-26 04:31 Grandiloquent Gentleman Note Added: 0023871
2013-08-26 04:38 tmhedberg Issue Monitored: tmhedberg
2013-08-26 04:42 tmhedberg Note Added: 0023872
2013-08-26 05:02 neil Note Added: 0023873
2013-08-26 05:02 neil Status new => resolved
2013-08-26 05:02 neil Fixed in Branch => 0.13 development branch
2013-08-26 05:02 neil Resolution open => done
2013-08-26 05:02 neil Assigned To => neil
2013-08-26 05:28 neil Note Edited: 0023873


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker