Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007505 [DCSS] Patches feature N/A 2013-08-23 20:57 2013-08-28 17:49
Reporter BlackSheep View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.13 ancient branch
Summary 0007505: Toggle to filter useless items from search results
Description I got hit with a brainstorm to filter useless items (using is_useless_item() to decide) from search results and managed to throw it together relatively quickly. To make the new flag and toggle info fit in console menus, I had to chop down the menu title a bit. I'd like to enhance the menu code to take into account window size when creating the title. But the code I've got is working well, and I'd like others to be able to look at it while I work on the menu.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Add-toggle-to-filter-useless-items-from-search-resul.patch [^] (8,383 bytes) 2013-08-23 20:57 [Show Content]
? file icon 0001-Variable-width-menu-title-for-stash-search-results.patch [^] (1,565 bytes) 2013-08-26 19:40 [Show Content]
? file icon 0001-Restore-match-count-to-search-results-and-move-toggl.patch [^] (4,549 bytes) 2013-08-27 19:41 [Show Content]

- Relationships

-  Notes
(0023876)
BlackSheep (reporter)
2013-08-26 19:42

It's rather hacky, relying on some breakpoints for screen width, but the second patch adds the match count back in if more than 92 columns are available, and extends the 'filter' label to 'filter useless' with more than 100 columns.
(0023879)
neil (administrator)
2013-08-27 06:56

I don't like losing the number of matches (most console players use 80x24), but I'm not sure what to remove instead. One possibility (though not ideal either) is to remove the word "filtered/unfiltered" and change the help to show "=:filter" if it's off and "=:unfilter" if it's on (maybe with a change of colour). Unfortunately, that doesn't buy you quite enough characters, but also condensing the double spaces into single might just do it.
(0023881)
BlackSheep (reporter)
2013-08-27 16:19
edited on: 2013-08-27 17:08

I'll play with it and see if I can fit the matches value in 80 cols. Another possibility is replacing Match(es) with something else. Maybe, "23 found" or somesuch, that way the only variable in the string is the number.

Edit: I misread what you wrote the first time, but now that I'm seeing it, I think combining the stack/sort/filter status labels with their keys makes the most sense.

Edit 2 (the Editing): how about the following:
123 matches, [a-z: travel ?/!: view -:show stacks /:sort by dist =:unfilter]

(where stacks toggles to items, dist toggles to name, and unfilter toggles to filter)

That's 79 columns for search results up to 999 matches, with the possibility of claiming 2 more columns by changing 'matches' to 'found'.

(0023883)
BlackSheep (reporter)
2013-08-27 19:42

The third patch restores match counts and moves the toggle status into the help text.

Bonus: travel/examine state is now preserved when you toggle one of the other options
(0023889)
neil (administrator)
2013-08-28 15:21
edited on: 2013-08-28 15:23

In trunk (0.13-a0-2865-g7a3ef1b and preceding), thanks! I made a few tweaks (0.13-a0-2867-g3e1dcb8) so that toggling stacks mode doesn't shift the following text, and so that it fits into 79 columns even when unfiltered (it was using 81 in unfiltered stacks mode).

I do have one concern, which is that it might not be clear that the strings indicate the current mode rather that what will happen if you press the labelled key. I'm kind of torn, though, because showing the opposite of the current mode (as I initially suggested) is also confusing.

(0023891)
BlackSheep (reporter)
2013-08-28 17:49

I wonder if it would make sense to use '?' for a help screen rather than a second travel/view toggle button. In any case, thanks for pushing it live. I left a question about detecting stray whitespace in the Coding section of the Tavern, if you have a chance to look at it.

- Issue History
Date Modified Username Field Change
2013-08-23 20:57 BlackSheep New Issue
2013-08-23 20:57 BlackSheep File Added: 0001-Add-toggle-to-filter-useless-items-from-search-resul.patch
2013-08-24 21:47 chris Issue Monitored: chris
2013-08-26 19:40 BlackSheep File Added: 0001-Variable-width-menu-title-for-stash-search-results.patch
2013-08-26 19:42 BlackSheep Note Added: 0023876
2013-08-27 06:56 neil Note Added: 0023879
2013-08-27 16:19 BlackSheep Note Added: 0023881
2013-08-27 16:51 BlackSheep Note Edited: 0023881
2013-08-27 17:08 BlackSheep Note Edited: 0023881
2013-08-27 19:41 BlackSheep File Added: 0001-Restore-match-count-to-search-results-and-move-toggl.patch
2013-08-27 19:42 BlackSheep Note Added: 0023883
2013-08-28 15:21 neil Note Added: 0023889
2013-08-28 15:21 neil Status new => resolved
2013-08-28 15:21 neil Fixed in Branch => 0.13 development branch
2013-08-28 15:21 neil Resolution open => done
2013-08-28 15:21 neil Assigned To => neil
2013-08-28 15:23 neil Note Edited: 0023889
2013-08-28 17:49 BlackSheep Note Added: 0023891
2013-08-28 17:49 BlackSheep Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker