Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007475 [DCSS] Patches feature have not tried 2013-08-16 01:46 2013-11-13 19:13
Reporter chris View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007475: Update vim syntax file for .des files
Description
This includes:
* recognizing WELCOME: and DESC: directives (the former unused)
* updating branches to include Spider, Zot, Forest, portal branches
* updating literally all the keywords (regrouped and commented)
  - many new modifiers and groups have been added
    * no longer recognizing the old wax wall glyph `a`
    * adding permarock, stairs, and glass (all types same for now) highlight
    * regrouping `hi` and `syn cluster` sections to match syntax.txt order
    * recognizing `weight:7` like `w:7`
    * recognizing `~` as trap glyph
    * removing the `O` glyph special cases for runes gone in 3bd72f5bf1f8
    * fancy god name highlights inside certain tags

Further TODO list with stuff that seems p.hard:
* recognizing `\` line continuations where applicable
* repairing the pretty broken lua handling, both `:inline` and {{blocks}}
* recognizing foo:bar modifiers and valid arguments for several directives
* expanding god name highlights to also cover e.g. branches
* maybe doing something about SHUFFLE: highlights similar to (N)SUBST


In your .vimrc, add this line to test:
autocmd BufNewFile,BufRead *.des *.des set syntax=levdes
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Update-vim-syntax-file-for-.des-files.patch [^] (13,124 bytes) 2013-08-16 01:46 [Show Content]
? file icon 0002-More-updates-for-.des-vim-syntax-file.patch [^] (12,308 bytes) 2013-08-16 17:24 [Show Content]
? file icon 0001-Minor-update-for-.des-vim-syntax-file.patch [^] (3,987 bytes) 2013-11-13 19:13 [Show Content]

- Relationships

-  Notes
(0023762)
chris (updater)
2013-08-16 01:51

Of course a way, *way* better approach towards the line continuations would be making `/` an implicit continuation in .des, because stuff like the following is just ugly and unnecessary:
KITEM: w = damaged long sword ego:none ident:pluses / damaged mace ego:none ident:pluses / \
   damaged flail ego:none ident:pluses / damaged spear ego:none ident:pluses / \
   damaged trident ego:none ident:pluses / damaged dagger ego:none ident:pluses / \
   damaged short sword ego:none ident:pluses / damaged lajatang ego:none ident:pluses / \
   damaged hand axe ego:none ident:pluses / damaged war axe ego:none ident:pluses
KITEM: a = damaged helmet ego:none ident:pluses / damaged pair of gloves ego:none ident:pluses / \
   damaged pair of boots ego:none ident:pluses / damaged leather armour ego:none ident:pluses / \
   damaged ring mail ego:none ident:pluses / damaged chain mail ego:none ident:pluses / \
   damaged plate armour ego:none ident:pluses / damaged cloak ego:none ident:pluses / \
   damaged shield ego:none ident:pluses
(0023767)
chris (updater)
2013-08-16 17:24
edited on: 2013-08-16 18:01

Uploaded another patch with more changes.
When applying, consider amending this fix that recognizes `luniq_` tags which I somehow forgot until now:
-syn match desEntry "\<uniq_\w*\>"
+syn match desEntry "\<l\=uniq_\w*\>"


(0023769)
neil (administrator)
2013-08-16 21:55

Both are in trunk (0.13-a0-2712-g07f05f3 and 0.13-a0-2714-g7a18f5a), thanks! I also included your luniq_* fix.

Feel free to re-open the bug when you have more patches
(0024404)
chris (updater)
2013-11-13 19:13

Small update attached.

- Issue History
Date Modified Username Field Change
2013-08-16 01:46 chris New Issue
2013-08-16 01:46 chris File Added: 0001-Update-vim-syntax-file-for-.des-files.patch
2013-08-16 01:51 chris Note Added: 0023762
2013-08-16 17:24 chris File Added: 0002-More-updates-for-.des-vim-syntax-file.patch
2013-08-16 17:24 chris Note Added: 0023767
2013-08-16 18:01 chris Note Edited: 0023767
2013-08-16 21:55 neil Note Added: 0023769
2013-08-16 21:55 neil Status new => resolved
2013-08-16 21:55 neil Fixed in Branch => 0.13 development branch
2013-08-16 21:55 neil Resolution open => done
2013-08-16 21:55 neil Assigned To => neil
2013-11-13 19:13 chris File Added: 0001-Minor-update-for-.des-vim-syntax-file.patch
2013-11-13 19:13 chris Note Added: 0024404


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker