Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007474 [DCSS] Patches feature N/A 2013-08-16 01:35 2015-04-11 07:26
Reporter gammafunk View Status public  
Assigned To gammafunk
Priority normal Resolution done  
Status closed   Product Branch 0.13 ancient branch
Summary 0007474: New unique: Asterion, a late-game minotaur of Makhleb
Description The implementation is in the asterion branch of my repo:

git://gitorious.org/~gammafunk/crawl/crawl-gammafunk.git [^]

Asterion is a late-game minotaur armed with a great mace and in the service of
Makhleb. He has monster versions of Major Destruction and Greater Servant as
spells. My aim for this monster is to help cover the player species without
uniques and to get a monster with some of Makhleb's active abilities. To that
end I'd consider using a different species (thats also missing a unique) and/or
using the 'lesser' Makhleb abilities and making a less powerful unique that appears earlier in the
game, of that's more appropriate.

The name is taken from Greek mythology as either the minotaur itself or a famous
king related to the minotaur. I'm going with a bloodthirsty king who was turned
into a minotaur, but suggestions wrt the name/background are welcome.

http://en.wikipedia.org/wiki/Asterion [^]

His current description:

"Once a king infamous for waging bloody campaigns against weaker nations,
Asterion was cursed to assume the horrible form of a minotaur. Exiled from his
kingdom, he now wanders the dungeon armed with a giant mace, in search of
victims of his rage.

These efforts are appreciated by Makhleb, who has granted the minotaur
destructive magic and the aid of demonic servants."

Stat-wise, Asterion is a minotaur, but with 20 HD, 175 HP, a 1d40 primary attack
(instead of 1d35), and the only resistances I've added are sinv and high MR.
Experience and placement-wise he's the same as sojobo. He always gets a good
great mace and good armour, either chain mail or plate.

The major destruct code is basically identical to the player version: it chooses
randomly from 7 beam types, including orb of electricity. The greater servant
calls either a t-2 demon or an executioner, like the player version. Currently
there's a range of 7 for major destruct, and no limit to the number of greater
servant summons. I think it might be good to at least limit the number of
servants to one or two, but we don't have the new summons caps in place for
monsters. The spell messages are themed to invoke Makhleb, but I haven't given
him any speech text yet.
Additional Information
Tags No tags attached.
Attached Files ? file icon asterion_updates_gce9ae6030.patch [^] (10,501 bytes) 2013-11-29 08:11 [Show Content]
? file icon asterion_new_g0b2097da5.patch [^] (39,050 bytes) 2014-01-20 02:47 [Show Content]
? file icon asterion_latest_g7e7b4d2.patch [^] (12,877 bytes) 2014-01-31 01:36 [Show Content]
? file icon tengu_move_g7e7b4d2.patch [^] (6,404 bytes) 2014-01-31 01:36 [Show Content]
? file icon unique_armour_g8160722.patch [^] (2,940 bytes) 2014-02-03 23:06 [Show Content]
? file icon asterion_tweak_gc7bb7542.patch [^] (1,814 bytes) 2014-02-09 08:01 [Show Content]

- Relationships

-  Notes
(0023866)
gammafunk (administrator)
2013-08-25 02:37

Removed a monster property that was part of an old attempt to do a servant cap, and updated the branch relative to current master.

Also, just to be clear the greater servant list is the same as the player ability; it chooses from the following list:
MONS_EXECUTIONER, MONS_GREEN_DEATH, MONS_BLIZZARD_DEMON, MONS_BALRUG, MONS_CACODEMON.
(0024437)
gammafunk (administrator)
2013-11-19 07:23

I've remade the asterion branch. The major change is I use the summons cap system so that the Asterion's greater servant spell has a cap of 2 (doesn't affect player version). The commit message is also more complete:

The repo is at:
gitorious.org:crawl/crawl-gammafunk.git
(0024448)
KiloByte (manager)
2013-11-22 01:41

I made a few changes, my version is in the official gitorious repository, branch "asterion".
(0024529)
gammafunk (administrator)
2013-11-29 08:19

I've uploaded a patch based on kilobyte's asterion branch fixing the remaining issues pointed out for this unique. The first commit gives monster speech text and a quote to Asterion. The second moves all bird people (Harpies and all Tengu, including Sojobo) to Q and makes Asterion's glyph blue, since that color on H is freed up as a result.

It seems that it's controversial to either remove Frances or Frederick, based on discussions in crawl-dev. Those in favor of keeping Frances would be happier with removing Frederick, and vice-versa. Difficulty-wise, Asterion is harder than Frederick, and generally even more so compared to Frances. FWIW, I'd be in favor of removing Frederick over Frances for that reason, if one must be removed.
(0024703)
gammafunk (administrator)
2013-12-12 02:32

I've had three ideas for replacing Asterion's greater servant ability (demon summoning) so as to make him more interesting and hopefully address the concern of him being overly difficult:

1) A "demonic idol" ability that would create an ornate demonic statue that would mesmerize the player. It's possible that the statue could inflict a bit of drain each turn in LOS as an added incentive for the player to do something about it (since the player may not need to move anywhere to continue hitting Asterion). This is a play off of obsidian axe in terms of theme. It's only slight twist from just giving Asterion mesmerize (I'm not proposing that), but the difference is a tactically interesting one. Only one statue would exist at a time, and he'd have a timeout before he could make another one. I think the statue shouldn't disintable, but perhaps it wouldn't have as much hp as an ice statue. This idea was floated in ##crawl-dev, and while no one objected I didn't get the sense it was viewed as "more interesting".

2) A "hellscape" ability. Since Makhleb is the god of hell, this ability would give Asterion a one-time ability (perhaps at hp <50%) to corrupt the level lucy-style with the forces of a randomly chosen hell branch, but without the massive group of neutral monsters. Instead it would make a a reasonably small random encounter of hell monsters the only t-2 and t-1 demons allowed being those from greater servant (green death, caco, balrog, blizzard demon, executioner). I think this would only occasionally make these high level demons, but the specific monster list handling could be tweaked. Having a chance of a hell-effect style themed explosion or cloud upon activation of this ability also seems reasonable. I assume the level corruption would be done the same way as for lucy's ability, just using the appropriate tiles/features from the randomly chosen hell branch.

3) Finally, a simple nerf to greater servant is to give Asterion a treant-style greater servant at hp <50%; in other words a one-time ability that creates an actual demon.

If any of these seems like they address the "interesting" or difficulty concerns sufficiently, let me know and I can make a patch relative to the git branch.
(0025025)
gammafunk (administrator)
2014-01-20 02:53

I've upload a new patch (asterion_new_g0b2097da5.patch) that removes the greater servant ability from Asterion, replacing it with spectral weapon. To give a bit more of makhleb theme, I've re-equiped Asterion to always have a demon weapon, large shield, and robe (instead of chain/plate). I was going to make a "makhlebified" version of spectral weapon to make a demon weapon specter, but just giving asterion a demon weapon seems simpler.

This patch incorporates 1kb's cleanups as well as my commits to move "bird people" to the Q glyph; it's a rebased version of the asterion branch 1kb made on gitorious (and is relative to latest trunk). It still has the commit removing Frances.
(0025154)
gammafunk (administrator)
2014-01-31 01:40

Uploaded a new patch (asterion_latest_g7e7b4d2.patch) where Asterion is nerfed down closer to Frances' level and shares her depth (as of latest trunk). This is out of concerns that we have perhaps too many late-game uniques going in at this point. I took out the commit removing Frances, since she's been adjusted in trunk and isn't going anywhere.

There's also another patch (tengu_move_g7e7b4d2.patch) to move all Tengu to 'Q', which is one of the nearly infinite proposals of how to free up 'H'. Asterion's color could go to e.g. blue after this was in place.
(0025156)
neil (administrator)
2014-01-31 20:30

In trunk (0.14-a0-2364-ge2f1143), thanks! I changed his colour to ETC_FIRE (Makhleb altar colour) to avoid conflict with plain minotaur, though I agree that moving around some glyphs would be a better idea.
(0025190)
Sar (reporter)
2014-02-03 19:38

I am not sure if this is the right place to report it, but I've fought Asterion and noticed strange thing about his spectral weapon: when he casts it, the spectral copy chases you with its spectral speed, not attacking, but blocking your LoS. This seems like a bug.
(0025195)
gammafunk (administrator)
2014-02-03 23:09

Uploaded unique_armour_g8160722.patch with two commits. The first gives Asterion a modest armour upgrade, removing is always good_item but giving him equal chance of leather armour, ring, scale, or chain mail instead of just a robe. This paired with the 25% hp increase grunt gave him should give Asterion a bit more staying power against well-armed/armoured melee players without rocking the boat too much.

The second patch gives the same change to Frances, who also currently just has a good_item robe. She was recently made a bit shallower, but again this is a modest change and her tile suggests she has heavier armour, at least.
(0025198)
sgrunt (administrator)
2014-02-04 03:40
edited on: 2014-02-04 03:41

0.14-a0-2426-g82bc141 is the latter of the two patches in unique_armour_g8160722.patch.

(To be clear: the immediately previous commit is the first of the two patches.)

(0025233)
gammafunk (administrator)
2014-02-09 08:04

In addition to 0008124, I've uploaded asterion_tweak_gc7bb7542.patch. This removes Asterion's shield and gives him signature weapon preferences. The greater relevance of spectral weapon in 8124 should help compensate the lack of shield. Another option would be downgrading to a medium shield instead (he looks kind of silly with it in tiles, but oh well). The large shield was a consistent complaint I head by players; it's "mennas' thing", which is not true (see louise), but the shield does make him more annoying to fight for ranged attackers (who are still at-risk from major destruction).
(0025244)
neil (administrator)
2014-02-09 17:47

Tweak_gc7bb7542 in trunk (0.14-a0-2512-g99fcc2e), thanks!
(0025501)
gammafunk (administrator)
2014-03-07 02:29

Asterion was merged in 0.14-a0-2364-ge2f1143. The glyph issue remains, but that can go under a different bug report, since we want to overhaul a bunch of glyphs.

- Issue History
Date Modified Username Field Change
2013-08-16 01:35 gammafunk New Issue
2013-08-16 01:36 gammafunk Issue Monitored: gammafunk
2013-08-25 02:37 gammafunk Note Added: 0023866
2013-11-19 07:23 gammafunk Note Added: 0024437
2013-11-22 01:41 KiloByte Note Added: 0024448
2013-11-29 08:11 gammafunk File Added: asterion_updates_gce9ae6030.patch
2013-11-29 08:19 gammafunk Note Added: 0024529
2013-12-12 02:32 gammafunk Note Added: 0024703
2014-01-20 02:47 gammafunk File Added: asterion_new_g0b2097da5.patch
2014-01-20 02:53 gammafunk Note Added: 0025025
2014-01-31 01:36 gammafunk File Added: asterion_latest_g7e7b4d2.patch
2014-01-31 01:36 gammafunk File Added: tengu_move_g7e7b4d2.patch
2014-01-31 01:40 gammafunk Note Added: 0025154
2014-01-31 20:30 neil Note Added: 0025156
2014-02-03 19:38 Sar Note Added: 0025190
2014-02-03 23:06 gammafunk File Added: unique_armour_g8160722.patch
2014-02-03 23:09 gammafunk Note Added: 0025195
2014-02-04 03:40 sgrunt Note Added: 0025198
2014-02-04 03:41 sgrunt Note Edited: 0025198
2014-02-09 08:01 gammafunk File Added: asterion_tweak_gc7bb7542.patch
2014-02-09 08:04 gammafunk Note Added: 0025233
2014-02-09 17:47 neil Note Added: 0025244
2014-03-07 02:29 gammafunk Note Added: 0025501
2014-03-07 02:29 gammafunk Status new => resolved
2014-03-07 02:29 gammafunk Fixed in Branch => 0.14 development branch
2014-03-07 02:29 gammafunk Resolution open => done
2014-03-07 02:29 gammafunk Assigned To => gammafunk
2015-04-11 07:25 gammafunk Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker