Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007441 [DCSS] Patches tweak random 2013-08-08 00:57 2013-08-15 15:09
Reporter chris View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.13 ancient branch
Summary 0007441: Spawn Jiyva altars a bit later than D:2
Description
From b4ee66ccb7292dbb13c7a49a8153fcde617e92ce Mon Sep 17 00:00:00 2001
From: Chris Oelmueller <chris.oelmueller@gmail.com>
Date: Sun, 28 Jul 2013 23:00:13 +0200
Subject: Spawn Jiyva altars a bit later than D:2

Also cut the weight of a vault placing four jellies at once, this is
overly dangerous even when they are not speed 10.
---
 crawl-ref/source/dat/des/altar/altar.des | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/crawl-ref/source/dat/des/altar/altar.des b/crawl-ref/source/dat/des/altar/altar.des
index 86f2440..fd3b3cc 100644
--- a/crawl-ref/source/dat/des/altar/altar.des
+++ b/crawl-ref/source/dat/des/altar/altar.des
@@ -405,7 +405,8 @@ NAME:  david_defended_altar_orc
 ### Altars to Jiyva ##########################################################
 
 NAME:  jiyva_altar_1
-DEPTH: D:2-20
+DEPTH: D:6-20
+WEIGHT: 5
 KFEAT: _ = altar_jiyva
 MONS:  jelly
 MAP
@@ -417,7 +418,7 @@ NAME:  jiyva_altar_1
 ENDMAP
 
 NAME:  jiyva_altar_2
-DEPTH: D:2-20
+DEPTH: D:4-20
 KFEAT: _ = altar_jiyva
 KITEM: 1 = dart
 KMONS: 1 = jelly
-- 
1.8.3.4
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0023672)
dpeg (administrator)
2013-08-08 01:07

I disagree with this one.

How is jiyva_altar_1 overly dangerous? You may have to skip the level (if you awoke the jellies) but, on the other hand, there's a god on D:2! If you're really concerned about the number of jellies, the proper way is to make the number (and perhaps also the type) of monsters level dependent. I can do this, if asked for.

And what is the problem with jiyva_altar_2? If I understand correctly, it is almost exclusively a source of level sounds!? Has someone been randomly teleported into this one?
(0023673)
chris (updater)
2013-08-08 01:24

There are enough mechanics spawning gods in early D already. Early Jiyva altars in my judgment have been made way too common recently. To me they don't even feel special of exciting anymore - cutting the weight can help that.

Jelly is not a D:2 monster by any means. Four jellies at once, right next to each other, definitely are not fair game.
Putting an altar to Jiyva next to them changes nothing about that. We don't start backgrounds with a god in some dangerous vault either, after all.
elliptic suggested D:10 onwards, so D:6 already is a compromise and if anything we should discuss increasing, not decreasing, that depth.

As for the dart gimmick one, it's surrounded by rock walls and spoiled players will find a way of breaking those walls. If it's only supposed to distract the player, I recommend removing the altar.

Oh and another reason for this patch is that a follow-up one changes jellies to be speed 10, if something was lacking context. This is not really related to the actual changes in this ticket however and I'd prefer to discuss it elsewhere.
(0023676)
BlackSheep (reporter)
2013-08-08 15:25

Your experience with the frequency of Jiyva altars doesn't match mine. Jiyva altars in early D remain rare. Forcing them to Temple depth not only decreases their frequency but also increases the likelihood of players already having a god when they encounter the altar.

If the concern is about early jellies, put in code that changes them to oozes below a certain depth. That seems to be a common way to give vaults with broad DEPTHs a graduated level of difficulty.
(0023678)
chris (updater)
2013-08-08 15:39

> Jiyva altars in early D remain rare. Forcing them to
> Temple depth not only decreases their frequency
> but also increases the likelihood of players already
> having a god when they encounter the altar.

And that is a problem because?

I don't even want a "graduated level of difficulty" (which surely would not be achieved by using the most harmless monster in crawl instead of jelly) because that would remove the option of converting to survive.
(0023681)
BlackSheep (reporter)
2013-08-08 16:16

It makes an already rare god option even rarer because early conversions are not currently survivable. And so far the only rationale provided is your judgment that Jiyva altars are "too common".

And you're not forced to replace all the jellies at early depths. If any jellies at all are such a big problem, put the vault behind a runed door. (Or, you know, revert their speed change which created this mess in the first place.)
(0023682)
chris (updater)
2013-08-08 16:25

Thanks for your opinion.
(0023731)
chris (updater)
2013-08-14 22:16

Fine with closing this now after dfdf40d4b061, thanks!
(0023736)
neil (administrator)
2013-08-15 15:08

Fixed in trunk (0.13-a0-2699-gdfdf40d); now at lower depths some or all of the jellies are replaced by oozes.

- Issue History
Date Modified Username Field Change
2013-08-08 00:57 chris New Issue
2013-08-08 01:07 dpeg Note Added: 0023672
2013-08-08 01:24 chris Note Added: 0023673
2013-08-08 15:25 BlackSheep Note Added: 0023676
2013-08-08 15:39 chris Note Added: 0023678
2013-08-08 16:16 BlackSheep Note Added: 0023681
2013-08-08 16:25 chris Note Added: 0023682
2013-08-14 22:16 chris Note Added: 0023731
2013-08-15 15:08 neil Note Added: 0023736
2013-08-15 15:08 neil Status new => resolved
2013-08-15 15:08 neil Fixed in Branch => 0.13 development branch
2013-08-15 15:08 neil Resolution open => done
2013-08-15 15:08 neil Assigned To => neil
2013-08-15 15:09 chris Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker