Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007433 [DCSS] Upload: Maps and Vaults minor have not tried 2013-08-06 20:52 2014-03-10 20:59
Reporter KennySheep View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007433: Vaults for the main dungeon
Description Some vaults for D
Additional Information
Tags No tags attached.
Attached Files ? file icon float.des [^] (12,204 bytes) 2013-08-06 20:52 [Show Content]
? file icon large_themed.des [^] (8,126 bytes) 2013-08-06 20:52 [Show Content]
? file icon large_abstract.des [^] (1,765 bytes) 2013-08-06 20:53 [Show Content]
? file icon edited vaults.des [^] (19,479 bytes) 2013-08-07 20:25 [Show Content]

- Relationships

-  Notes
(0023660)
neil (administrator)
2013-08-06 23:32

I worry about the missing_parent vault and the chance of pain and distortion brand. Not only are they quite a bit more powerful than the others, but their flavour is different since those things are actually made by the gods in question, unlike (say) amulets of rage.
(0023661)
sgrunt (administrator)
2013-08-07 03:20

I haven't gone through these in great detail as yet, but some of them still need a great deal of work (a couple of them may never be usable at all). I don't mean to discourage you, but I hope looking through my first round of comments on these will help improve them:

church_of_the_atheists: a gratuitous feature rename is a bad idea, particularly if there's no description to go with it.
demon_hangout: the demonspawn monster isn't really meant to be used as a regular enemy; I would stick with just the demons.
ogre_elephant_herders: as far as I can tell, there isn't an altar (so the KMONS and KFEAT lines are unnecessary) and you only have two monster placements (so the ", ogre, ogre mage") is unnecessary.
spore_jar: having fungi be sealed in is a bad idea - given the teleport trap, the entire level will eventually become polluted without an unprepared player having the means to clear it out. I do not think this is a concept which will ever be workable.
face: eyes and giant orange brains fly, so the shaft traps are completely pointless.
the_goblin_king: perhaps have a chance of placing Ijyb instead of a hobgoblin on D:2-? (KMONS: 1 = hobgoblin / Ijyb, hobgoblin ... KMONS: 2 = goblin)
googly_eyes: see previous note about shaft traps.
yak_hideout: I am not sure if the yaks are supposed to be consistently sealed in or not; it's too randomised for me to be able to tell. In any case, siccing a yak pack on the player on D:5 is too out-of-depth - perhaps this can be reworked into something to place in Lair?
phantopolis: way, way, way overboard with the fog.
treasure_room: three 8s on D:3 is overkill, runed door and glass or no, and the loot is pathetic for that level of challenge; you need either more loot, better loot, or both, and to either increase the depth or replace the loot/monsters with something less overwhelming at low depths.
four_rooms: see previous about loot; an 8 on D:5 is going to be too lethal, so see previous note about depth.
alarming_item: with the trap as it is, this is an autoexplore trap - at least make the trap known (cf. grunt_tough_drop).
murder_the_trees: a guaranteed wand of fire as early as D:5 is ... inadvisable.
demon_jail: the amount of loot this has doesn't correspond to the challenge it would pose.
bagend: as with murder_the_trees, I don't like the idea of guaranteeing a very good item (here, the ring of invisibility) as early as D:3. I also don't know what you're trying to accomplish with the z in the final room of the vault, or with all of the empty space in the rooms (other than for purely cosmetic purposes).
digestion: large, full of dangerous monsters (possibly placing multiple acid blobs as early as D:17), and completely bereft of loot? Why?
forest_fire: there's probably a way to do this without generating orc knights with guaranteed plate of rF+ and wands of fire, e.g. using more efreets or other fire-throwing enemies (hell knights, dragons, etc).
green_arena: is this really intended to be ORIENT: east? At the very least it would need to be ORIENT: northeast to connect up to the rest of the level properly. This is also completely bereft of loot, which is inappropriate for the level of challenge it presents.
snake: I think this could also use a bit more loot. (Also, place it in Snake occasionally!)
(0023662)
KennySheep (reporter)
2013-08-07 06:46

Your notes are noted, I'll get to work on these fixes. Thanks a lot for the quick feedback too!

The only thing I disagree with you about is the shaft traps in face/googly_eyes, which were intended to let players exit the sealed off areas if they got unlucky with a teleport/escape hatch/whatever. I'll still remove them in favor of no teleport into tags though.
(0023663)
sgrunt (administrator)
2013-08-07 06:47

If you want to provide the player a means of escape, use escape hatches, not shafts - if they can get stuck, they can get stuck in there more than once.
(0023667)
MarvinPA (developer)
2013-08-07 13:12

Vaults whose only purpose is to be silly art aren't good either, anyway. Nor are vaults whose only purpose is to be a blatant reference to some book or other without actually being interesting vaults themselves. Vaults with guaranteed, non-randomised traps should have those traps marked as known.
(0023670)
KennySheep (reporter)
2013-08-07 20:45

Resubmitted with the following changes:

missing_parent: No longer has a chance of giving pain or distortion weapons, no longer can have altars to Lugonu.

church_of_the_atheists: Altar has been removed

demon_hangout: Demonspawn has been removed

ogre_elephant_herders: Useless junk has been removed, and I am very sorry I didn't proofread that one the first time around

yak_hideout: The point of this vault was only ever to make the player fight out-of-depth yaks, but putting some plants and bushes between the player and the yaks to let the player run away if need be. It's been moved to floor 7 instead of floor 5 to make the yaks a lot less out-of-depth. If this isn't enough it can be moved further down in the dungeon (or just removed)

bagend: Guaranteed ring has been removed, as well as half the empty rooms. The amount of loot and halflings have been increased slightly. It now only spawns on d:3-4, the mid dungeon version with dwarves and a wizard has been removed

treasure_room, four_rooms: More loot added and moved to D:12

alarming_item: The trap is now known, the item is better. It was also moved to D:12

snake: Snake added to depth, more loot added

green_arena: Orient set to north, about the same amount of loot added as is currently found in snake

murder_the_trees: Moved to D:12 where the wand of fire won't be as helpful

kobold_camp: Loot added

seaside_town: Made the loot that was there a little less terrible

spore_jar: Removed the teleporters, added no_rtele_into tags. It's a purely cosmetic vault now.

face: Added no_rtele_into tags for the eyes, nose and brain. small amount of loot added to the brain

forest_fire: Replaced the orc knights with a storm dragon

demon_jail: Added three more items into the loot room

digestion: Changed the layout a little, pre-set the number of acid blobs to prevent a swarm of them from spawning, added some good items to the brain room and mundane items in the stomach

The following maps have been removed:

googly_eyes: an out-of-depth golden eye and one monster to finish the job was a terrible idea for a vault

care_of_magical_creatures: dull, only exists to be a reference

phantopolis: the point was only ever to be twisty passages semi-constantly hard to see down due to fog. evidently this is not an ok use of fog
(0025542)
sgrunt (administrator)
2014-03-10 20:59

I've landed the following:
- kobold_lugonu_temple
- orc_sif_temple - randomised the number of orc wizards present.
- demon_hangout - kind of leery about this one, but we have other vaults at this depth that place lone common demons of various sorts.
- ogre_elephant_herders - places in Depths, and has a herd of dire elephants instead of plain elephants.
- the_goblin_king
- steamy
- treasure_room (as a minivault)
- four_rooms (as a minivault)
- demon_jail
- seaside_town
- kobold_camp (with traps removed)
- green_arena
- snake

I am not landing the following:
- church_of_the_atheists - utilises dummy monsters (demigods) as enemies.
- missing_parent - ditto.
- spore_jar - even (especially?) as a cosmetic vault this isn't a workable concept.
- face - seems primarily to exist to show a silly design on the map without much else compelling about it.
- yak_hideout - with proposed changes to trees this becomes excessively spoilery.
- escape_route - too hamfisted (I've been guilty of the same basic design in the past, but the offending vault is probably going to change anyway).
- alarming_item - inherently spoilery.
- ambush - this concept has been done to death already.
- murder_the_trees - previous vaults with this basic idea have gone away as being too reliant on the player having specific equipment.
- bagend - reliant on monsters that are primarily dummy monsters (halflings).
- digestion - see face.
- forest_fire - with discussion around changes to trees and/or forest fires, the concept of this vault isn't likely to stand up over time.

I think that's everything, so we're done here.

- Issue History
Date Modified Username Field Change
2013-08-06 20:52 KennySheep New Issue
2013-08-06 20:52 KennySheep File Added: float.des
2013-08-06 20:52 KennySheep File Added: large_themed.des
2013-08-06 20:53 KennySheep File Added: large_abstract.des
2013-08-06 23:32 neil Note Added: 0023660
2013-08-07 03:20 sgrunt Note Added: 0023661
2013-08-07 06:46 KennySheep Note Added: 0023662
2013-08-07 06:47 sgrunt Note Added: 0023663
2013-08-07 13:12 MarvinPA Note Added: 0023667
2013-08-07 20:25 KennySheep File Added: edited vaults.des
2013-08-07 20:45 KennySheep Note Added: 0023670
2014-03-10 20:59 sgrunt Note Added: 0025542
2014-03-10 20:59 sgrunt Assigned To => sgrunt
2014-03-10 20:59 sgrunt Status new => resolved
2014-03-10 20:59 sgrunt Resolution open => done
2014-03-10 20:59 sgrunt Fixed in Branch => 0.14 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker