Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007428 [DCSS] Bug Report trivial always 2013-08-04 23:39 2013-08-05 02:12
Reporter CaptainHaddock View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007428: Throwing Hunters do not autopickup appropriate ammo
Description Roll a hunter of some class, and select the throwing weapon for your size. You will not have that ammo type selected for autopickup.

If you instead select bow, sling, or x-bow, you will have that ammo tpye set to autopickup.

The bug (if this isn't deliberate) seems to be in ng-setup.cc, in the function _update_weapon, where autopickup for thrown projectile types isn't set.

Patch attached
Additional Information
Tags No tags attached.
Attached Files ? file icon fix_0007428.patch [^] (1,678 bytes) 2013-08-04 23:43 [Show Content]

- Relationships

-  Notes
(0023651)
neil (administrator)
2013-08-05 02:12

Applied in trunk (0.13-a0-2620-g9c1726f), thanks!

- Issue History
Date Modified Username Field Change
2013-08-04 23:39 CaptainHaddock New Issue
2013-08-04 23:43 CaptainHaddock File Added: fix_0007428.patch
2013-08-05 02:12 neil Note Added: 0023651
2013-08-05 02:12 neil Status new => resolved
2013-08-05 02:12 neil Fixed in Branch => 0.13 development branch
2013-08-05 02:12 neil Resolution open => done
2013-08-05 02:12 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker