Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007398 [DCSS] Bug Report minor have not tried 2013-07-27 02:42 2013-08-01 22:59
Reporter CreepingCrawled View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007398: Spirit wolves act hostile even when pacified
Description Crawl Version: crawl.akrasiac.org on Console "Dungeon Crawl Stone Soup Trunk" 0.13-a0-2531-g2ad9301

OS: Linux version 3.1.10

Crash: this bug doesn't cause a crash

Here's what happened:
In the Forest branch, I attacked a pack of spirit wolves, which then howled and then I pacified the whole pack. Even though the wolves were pacified and they were in a large room, the wolves still followed and attacked me. I ended up surrounded by pacified wolves which kept attacking me, which forced me to either teleport; blink; or attack them, which would cause me to receive Elyvilon penance. While I was running towards the stairs after I fought my way out of that pack of spirit wolves, the Howl status wore off. It seems that the cause is either due to the Howl status or maybe that summoned monsters can't be effectively pacified.

Expected behavior: Wolves attack me maybe a few times and then wander off.

TTYREC of the bug:
To see the bug, start watching http://crawl.akrasiac.org/rawdata/CreepingCrawled/2013-07-26.15:59:54.ttyrec [^] from "Time: 45860" to "Time: 45970" or just search for "Howl" and watch until I go upstairs.

Save file link: http://crawl.akrasiac.org/saves/CreepingCrawled-crawl-git-2ad93012e7-130726-2011.tar.bz2 [^]
Additional Information
Tags patch
Attached Files ? file icon 0001-Fix-spectral-wolf-pacification-bug.patch [^] (1,183 bytes) 2013-08-01 20:59 [Show Content]

- Relationships
has duplicate 0007385resolvedMarvinPA Chimeric spectral wolves howl. 

-  Notes
(0023615)
cjo (reporter)
2013-08-01 21:02

Patch attached. It didn't relate to the howl status, but to the way that haunting and pacification failed to interact.
(0023618)
neil (administrator)
2013-08-01 22:59

cjo's fix is applied in trunk (0.13-a0-2587-g7004df4), thanks for reporting the bug!

- Issue History
Date Modified Username Field Change
2013-07-27 02:42 CreepingCrawled New Issue
2013-07-31 11:38 mumra Relationship added has duplicate 0007385
2013-08-01 20:59 cjo File Added: 0001-Fix-spectral-wolf-pacification-bug.patch
2013-08-01 21:02 cjo Note Added: 0023615
2013-08-01 22:17 neil Tag Attached: patch
2013-08-01 22:42 neil Status new => assigned
2013-08-01 22:42 neil Assigned To => neil
2013-08-01 22:59 neil Note Added: 0023618
2013-08-01 22:59 neil Status assigned => resolved
2013-08-01 22:59 neil Fixed in Branch => 0.13 development branch
2013-08-01 22:59 neil Resolution open => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker