Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007321 [DCSS] Bug Report minor have not tried 2013-07-09 03:20 2013-11-26 16:20
Reporter 78291 View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007321: Xom can't actually summon greater demon allies
Description In theory Xom would summon a greater demon (or daeva) ally in _xom_random_demon() if random2(1000 - (MAX_PIETY - sever) * 5) >= 850. However severity is player's piety - 100 (so between 0-100), so the largest result possible is (1000 - (200 - 100) * 5), or 500. Presumably this is supposed to be a possible result since there are a lot of speech lines for it.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0024504)
MarvinPA (developer)
2013-11-26 16:20
edited on: 2013-11-26 16:21

Fixed by removing the related greater demon/holy summoning code - it'd probably be good to allow Xom to summon more varied things but this seems to have not worked for years and I think it'd be better to implement something new from scratch than to try and figure out how to fix/rework the current state.


- Issue History
Date Modified Username Field Change
2013-07-09 03:20 78291 New Issue
2013-08-05 18:04 MarvinPA Issue Monitored: MarvinPA
2013-11-26 16:20 MarvinPA Note Added: 0024504
2013-11-26 16:20 MarvinPA Status new => resolved
2013-11-26 16:20 MarvinPA Fixed in Branch => 0.14 development branch
2013-11-26 16:20 MarvinPA Resolution open => done
2013-11-26 16:20 MarvinPA Assigned To => MarvinPA
2013-11-26 16:20 MarvinPA Issue End Monitor: MarvinPA
2013-11-26 16:21 MarvinPA Note Edited: 0024504


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker