Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007309 [DCSS] Patches feature N/A 2013-07-05 11:13 2015-04-11 07:28
Reporter gammafunk View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status closed   Product Branch 0.13 ancient branch
Summary 0007309: New forest vaults, including a forest end, and a generic overflow temple
Description I include the overflow temple in this patch since it wasn't finished when grunt whisked my other overflow temples away to the repository. Let me know if there's still a need for more of these kinds of vaults.

For forest.des, there are 4 ordinary vaults and a forest end. The forest end has a problem with subvaults that I'd appreciate help with.

* gammafunk_forest_yreds_foothold
Yred has established a foothold in forest to spread the good word. His chapel,
which houses 4 acquire-level items and additional loot, is guarded by a profane
servitor and a nasty side-kick. Access to the chapel is granted through one of
six passages in the surrounding (slighty withered) woods.

* gammafunk_forest_sporulate
Some forest ranged attackers have set up a giant spore trap. They're holed-up
in a bush barricade to protect themselves from the exploding spores and guard a
few good items. The vault has two to six giant spores and some ballistomycetes,
and all enemies are patrolling to hopefully keep the trap set.

* gammafunk_forest_enchanted_lake
A hidden river runs under a mountain, feeding into an enchanted lake. Some
water nymphs to play in the lake along with water enemies in the river. The
river leeds to some loot, which is guarded. Some land-based enemies, including
an apis, surround the lake.

* gammafunk_forest_bear_cave
A den of ancient bears. They guard a small pile of loot.

* gammafunk_forest_water_palace (New forest end)
A palace where denizens of the forest gather to worship a powerful diety. The
enemy and loot quantities are on-par with grunt_forest_end_chambers, but I'd
welcome feedback regarding balance.

Currently the subvault placement is broken for this vault, and I can't figure
out why. The subvault areas are usually just grass, but sometimes a single
subvault will place correctly, or part of it will place. Testing with the
subvaults in a smaller map worked fine, and even commenting out the header lines
after the second SUBVAULT in water_temple didn't fix the problem. The purpose of the subvaults
is to randomize the amount/location of the 3x3 columns sections.
Additional Information
Tags No tags attached.
Attached Files ? file icon gammafunk_vaults_ge1c5d4310.patch [^] (10,306 bytes) 2013-07-05 11:13 [Show Content]
? file icon gammafunk_vaults-fixed_ge1c5d4310.patch [^] (10,673 bytes) 2013-07-05 22:06 [Show Content]
? file icon gammafunk_vaults_e1c0d723.patch [^] (10,658 bytes) 2013-07-07 05:30 [Show Content]

- Relationships

-  Notes
(0023401)
gammafunk (administrator)
2013-07-05 22:10

I uploaded a fixed patch with working subvaults for gammafunk_forest_water_palace. The problem was attemping to place the subvault twice using the same glyph. I use different glyph for each instance of any subvault now and do a shuffle to choose the subvault pairs. This map generates properly under &P now. I also added no_vmirror so that the column subvaults always get placed in the same vertical orientation.
(0023413)
gammafunk (administrator)
2013-07-07 05:31
edited on: 2013-07-07 05:33

Uploaded gammafunk_vaults_e1c0d723.patch

The only changes are removal of ORIENT line from overflow temple vault, and it's based off e1c0d723.

(0023424)
sgrunt (administrator)
2013-07-10 06:04

I've landed these as 0.13-a0-2317-ge9fcc15, with a couple of very minor cosmetic (definition-wise) adjustments and allowing _enchanted_lake to place at any Forest depth (it doesn't appear to be intended to be an ending).

- Issue History
Date Modified Username Field Change
2013-07-05 11:13 gammafunk New Issue
2013-07-05 11:13 gammafunk File Added: gammafunk_vaults_ge1c5d4310.patch
2013-07-05 22:06 gammafunk File Added: gammafunk_vaults-fixed_ge1c5d4310.patch
2013-07-05 22:10 gammafunk Note Added: 0023401
2013-07-05 22:53 gammafunk Issue Monitored: gammafunk
2013-07-07 05:30 gammafunk File Added: gammafunk_vaults_e1c0d723.patch
2013-07-07 05:31 gammafunk Note Added: 0023413
2013-07-07 05:33 gammafunk Note Edited: 0023413
2013-07-10 06:04 sgrunt Note Added: 0023424
2013-07-10 06:04 sgrunt Assigned To => sgrunt
2013-07-10 06:04 sgrunt Status new => resolved
2013-07-10 06:04 sgrunt Resolution open => done
2013-07-10 06:04 sgrunt Fixed in Branch => 0.13 development branch
2015-04-11 07:28 gammafunk Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker