Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007307 [DCSS] Upload: Maps and Vaults trivial N/A 2013-07-05 05:18 2014-03-11 01:01
Reporter Lightli View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007307: Some vaults
Description Here are some vaults.

Not much else to say.
Additional Information
Tags No tags attached.
Attached Files ? file icon lightli vault stuff.des [^] (4,236 bytes) 2013-07-05 05:18 [Show Content]
? file icon lightli vault stuff [fixed].des [^] (4,243 bytes) 2013-07-05 09:37 [Show Content]
? file icon a vault.des [^] (383 bytes) 2013-11-11 06:11 [Show Content]
? file icon a crypt vault.des [^] (1,501 bytes) 2013-11-23 06:37 [Show Content]
? file icon e4m8 (gehenna ending maybe).des [^] (3,315 bytes) 2013-12-13 21:01 [Show Content]
? file icon e4m8 (edited).des [^] (3,366 bytes) 2013-12-13 21:55 [Show Content]
? file icon e4m8 (more edited).des [^] (3,562 bytes) 2013-12-22 23:55 [Show Content]
? file icon a entry vault based off of quake.des [^] (452 bytes) 2013-12-24 05:41 [Show Content]
? file icon wizard_tower.des [^] (556 bytes) 2014-01-29 04:33 [Show Content]

- Relationships

-  Notes
(0023395)
Lightli (reporter)
2013-07-05 09:33

Via a massive amount of trial and error, everything now works!
(0024384)
Lightli (reporter)
2013-11-11 06:11

Bumping this back to the top so the vaults might get implemented; also here's a runelock vault.
(0024388)
dpeg (administrator)
2013-11-11 23:36

The concepts look alright, I especially like additional portal vault entries. I have no time to revise right now, and there is something to do (I thinking the burning bush vault is still not quite right). If nothing happens with these maps, I'll take care of them (read: before 0.14 release). Thank you!
(0024472)
Lightli (reporter)
2013-11-23 06:37

Bumping again with another vault, this time a Crypt ending.

I'm worried it might actually be a bit too hard, so feel free to tone it down a notch if it looks too brutal.
(0024724)
Lightli (reporter)
2013-12-13 21:00

Here's another vault, this time a Gehenna ending.

Again, I'm worried it might be too hard. Yes, I'm saying this about a Hell ending. Balancing feedback direly wanted.
(0024725)
Lightli (reporter)
2013-12-13 21:54

Updating the Gehenna vault to lower the difficulty a notch; smoke demon numbers are randomized now, and there are now at least a few chokepoints for melee characters to use.

Probably still needs more adjustment though.
(0024728)
evilmike (developer)
2013-12-14 15:24

Your geh ending puts loot hidden inside a diggable pillar. People have worked hard to remove crap like that and there's no sense in adding more of it. You can keep the digging requirement but you need to replace one of the walls with a statue or something.

Also it looks like players can just break outside the stone walls of the vault. Stuff out there would just be diggable rock I think, which means it's possible to tunnel outside of the level. A layer of permarock outside the stone can fix that.
(0024814)
Lightli (reporter)
2013-12-22 23:53

Done and done. The massive pillar now has a grate in it to let you see the loot inside before hand, and the other one now only has 3 heal wound potions in it.

Also as requested added a layer of permarock around the stone; the very leftmost part of the vault hasn't been touched since as it is the vault is already skirting the horizontal size limit.

Threw another two hellions in; as it is the area they're in is vastly safer than the second main room. To compensate and make going into those side corridors a better idea in general, added another choke point so that melee characters aren't forced into pulling everything all the way back to the chokepoint connecting the two main rooms.
(0024831)
Lightli (reporter)
2013-12-24 05:40

Here's a vault that isn't based off of Doom for once!

It's based off of Quake instead.
(0025128)
Lightli (reporter)
2014-01-29 04:32

Here's another tiny vault that popped into my head at random.
(0025317)
infiniplex (reporter)
2014-02-15 07:46

The wizard tower has a '1' and a '2' in it, but only defines 1 monster. Were you intending to use this for some sort of randomization?
(0025358)
Lightli (reporter)
2014-02-22 05:39

Oh, define the 2 as a crimson imp.

Oops.
(0025552)
sgrunt (administrator)
2014-03-10 23:03

I've looked through most of these. The following are in with (often major) adjustments:
- _flooded_house
- _minifort
- The portal entries (except _arctic_zoo)
- _lavapool
- _bank_vault (as a Vaults hard room)
- _wizard_tower

I'm not adding the following:
- _around_the_bush (dancing around an enemy that normally doesn't appear in the game to get a couple of scrolls is a fundamentally bad concept)
- _arctic_zoo (glass showcases like this are generally frowned upon these days)
- _ring_of_pain (this concept has been done to death)
- _bored_captain (we already have Depths entries that do something similar)

_quake has apparently already been added.

This leaves _unholy_cathedral and _unto_the_cruel, which need to be gone over in more detail.
(0025555)
sgrunt (administrator)
2014-03-11 01:01

...and now those are in (in drastically changed forms), too.

- Issue History
Date Modified Username Field Change
2013-07-05 05:18 Lightli New Issue
2013-07-05 05:18 Lightli File Added: lightli vault stuff.des
2013-07-05 09:33 Lightli Note Added: 0023395
2013-07-05 09:37 Lightli File Added: lightli vault stuff [fixed].des
2013-11-11 06:11 Lightli Note Added: 0024384
2013-11-11 06:11 Lightli File Added: a vault.des
2013-11-11 23:36 dpeg Note Added: 0024388
2013-11-23 06:37 Lightli Note Added: 0024472
2013-11-23 06:37 Lightli File Added: a crypt vault.des
2013-12-13 21:00 Lightli Note Added: 0024724
2013-12-13 21:01 Lightli File Added: e4m8 (gehenna ending maybe).des
2013-12-13 21:54 Lightli Note Added: 0024725
2013-12-13 21:55 Lightli File Added: e4m8 (edited).des
2013-12-14 15:24 evilmike Note Added: 0024728
2013-12-22 23:53 Lightli Note Added: 0024814
2013-12-22 23:55 Lightli File Added: e4m8 (more edited).des
2013-12-24 05:40 Lightli Note Added: 0024831
2013-12-24 05:41 Lightli File Added: a entry vault based off of quake.des
2014-01-29 04:32 Lightli Note Added: 0025128
2014-01-29 04:33 Lightli File Added: wizard_tower.des
2014-02-15 07:46 infiniplex Note Added: 0025317
2014-02-22 05:39 Lightli Note Added: 0025358
2014-03-10 23:03 sgrunt Note Added: 0025552
2014-03-10 23:03 sgrunt Assigned To => sgrunt
2014-03-10 23:03 sgrunt Status new => assigned
2014-03-11 01:01 sgrunt Note Added: 0025555
2014-03-11 01:01 sgrunt Status assigned => resolved
2014-03-11 01:01 sgrunt Resolution open => done
2014-03-11 01:01 sgrunt Fixed in Branch => 0.14 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker