Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007304 [DCSS] Bug Report minor have not tried 2013-07-04 09:54 2014-08-20 07:33
Reporter Scrotar View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007304: Orc warrior "unaffected by your stone of flame"
Description Orc warriors seem to be unaffected by elemental missile attacks (sling bullet and sling stones at least). No gear is the culprit and there doesn't seem to be any other factors involved.

Username BlackSwan on CAO.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0023387)
neil (administrator)
2013-07-04 12:37
edited on: 2013-07-04 12:39

I just tested and I was able to damage an orc warrior with a sling and bullets of flame. What was the exact message? Do you have a link to the game so we can view a ttyrec, or information so we can look it up in the bots?

"Unaffected" is, as far as I can tell, used only when a monster resists an enchantment, or is immune to a blowgun because it is undead or nonliving.

(0023399)
BlackSheep (reporter)
2013-07-05 16:36

When I hit a monster with a missile that does no damage, I just see "The stone hits the orc warrior." and the only way I know it did no damage is that its health bar didn't appear. When I do the same thing with a sling of flaming I see:

The stone of flame hits the orc warrior.
The orc warrior appears unharmed.

I'm guessing this is what the submitter saw.
(0027058)
PleasingFungus (administrator)
2014-08-20 07:33

Slings are good now.

- Issue History
Date Modified Username Field Change
2013-07-04 09:54 Scrotar New Issue
2013-07-04 12:37 neil Note Added: 0023387
2013-07-04 12:39 neil Note Edited: 0023387
2013-07-05 16:36 BlackSheep Note Added: 0023399
2014-08-20 07:33 PleasingFungus Note Added: 0027058
2014-08-20 07:33 PleasingFungus Status new => resolved
2014-08-20 07:33 PleasingFungus Fixed in Branch => 0.16 development branch
2014-08-20 07:33 PleasingFungus Resolution open => done
2014-08-20 07:33 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker