Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007293 [DCSS] Patches minor always 2013-07-02 11:51 2013-07-03 01:41
Reporter qoala View Status public  
Assigned To mumra
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007293: Fix animated weapons of protection
Description Spectral/Dancing weapons of protection weren't getting the AC bonus, since the weapon was given (and thus AC changed for the bonus) before the ghost_demon's stats were generated and applied.

My fix silently unwields and wields the weapon around the stat modifications in ghost_demon_init.
Additional Information
Tags No tags attached.
Attached Files ? file icon animated_protection_weapons_fix.patch [^] (1,444 bytes) 2013-07-02 11:51 [Show Content]

- Relationships

-  Notes
(0023376)
mumra (developer)
2013-07-03 01:41

Applied in trunk, thanks!

- Issue History
Date Modified Username Field Change
2013-07-02 11:51 qoala New Issue
2013-07-02 11:51 qoala File Added: animated_protection_weapons_fix.patch
2013-07-03 01:41 mumra Note Added: 0023376
2013-07-03 01:41 mumra Status new => resolved
2013-07-03 01:41 mumra Fixed in Branch => 0.13 development branch
2013-07-03 01:41 mumra Resolution open => done
2013-07-03 01:41 mumra Assigned To => mumra


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker