Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007291 [DCSS] Bug Report minor have not tried 2013-07-01 14:32 2014-02-24 14:04
Reporter Whales View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007291: Inappropriate undead (zombies, simulacra)
Description I have noticed inappropriate undead monsters generating in 0.13. These include multiple sky beast zombies and a shapeshifter simulacrum. I assume the former is a bug, since sky beast corpses aren't raisable, while the latter is just novel to me.
Additional Information
Tags No tags attached.
Attached Files jpg file icon giantamoebazombie.jpg [^] (33,976 bytes) 2013-10-21 15:35

- Relationships

-  Notes
(0023541)
MarvinPA (developer)
2013-07-23 17:53

Those things are zombifiable now.
(0023542)
MarvinPA (developer)
2013-07-23 18:24

Oops, except the shapeshifter thing is indeed a bug (spectral shapeshifters are meant to work, but not zombies/skeletons/simulacrum, if I understand correctly).
(0023582)
Vinterriket (reporter)
2013-07-28 19:12

The sky beast zombie uses a bear zombie tile. Not sure if this is intended or just a placeholder for a future tile...
(0024226)
slitherrr (reporter)
2013-10-21 15:35
edited on: 2013-10-21 15:35

I've also seen this with a giant amoeba zombie, using the "detected invisible creature" tile (See attached)

(0025397)
MarvinPA (developer)
2014-02-24 14:04

Fixed.

- Issue History
Date Modified Username Field Change
2013-07-01 14:32 Whales New Issue
2013-07-23 17:53 MarvinPA Note Added: 0023541
2013-07-23 17:53 MarvinPA Status new => resolved
2013-07-23 17:53 MarvinPA Fixed in Branch => 0.13 development branch
2013-07-23 17:53 MarvinPA Resolution open => no change required
2013-07-23 17:53 MarvinPA Assigned To => MarvinPA
2013-07-23 18:24 MarvinPA Assigned To MarvinPA =>
2013-07-23 18:24 MarvinPA Note Added: 0023542
2013-07-23 18:24 MarvinPA Status resolved => new
2013-07-23 18:24 MarvinPA Resolution no change required => reopened
2013-07-28 19:12 Vinterriket Note Added: 0023582
2013-10-21 15:35 slitherrr Note Added: 0024226
2013-10-21 15:35 slitherrr File Added: giantamoebazombie.jpg
2013-10-21 15:35 slitherrr Note Edited: 0024226
2014-02-24 14:04 MarvinPA Note Added: 0025397
2014-02-24 14:04 MarvinPA Status new => resolved
2014-02-24 14:04 MarvinPA Resolution reopened => done
2014-02-24 14:04 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker