Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007289 [DCSS] Source Cleanup minor N/A 2013-06-30 21:16 2013-07-01 01:11
Reporter pubby View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0007289: Remove use of 'you' inside player member functions
Description Removed use of 'you' inside player member functions.

'you' seemed to be pointless in such context anyways, and lead to some
const correctness bugs since '*this' could have a different const-ness
from 'you'.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Remove-use-of-you-inside-player-member-functions.patch [^] (37,837 bytes) 2013-06-30 21:16 [Show Content]

- Relationships

-  Notes
(0023359)
neil (administrator)
2013-07-01 01:11

Applied in trunk (0.13-a0-2173-gfaf8416), thanks!

- Issue History
Date Modified Username Field Change
2013-06-30 21:16 pubby New Issue
2013-06-30 21:16 pubby File Added: 0001-Remove-use-of-you-inside-player-member-functions.patch
2013-07-01 01:11 neil Note Added: 0023359
2013-07-01 01:11 neil Status new => resolved
2013-07-01 01:11 neil Fixed in Branch => 0.13 development branch
2013-07-01 01:11 neil Resolution open => done
2013-07-01 01:11 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker