Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007285 [DCSS] Patches tweak N/A 2013-06-29 13:55 2013-07-17 15:50
Reporter qoala View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007285: Spectral Weapon buffs & fineff fixes
Description The long awaited buffs to Spectral Weapon:
- damage now scales with weapon skill, but this effect is proportional to spell power as well
- AC slightly improved, EV significantly so
- Beams can be freely fired through allied spectral weapon (like battlesphere)
- damage sharing is now half the damage taken by the weapon
- damage sharing reworked to use the actual damage taken by the weapon and use a fineff so that it leaves the player with at least 1hp regardless of target order in an AoE attack.

Fixed some issues with fineffs:
specifically, ::hurt being called twice on shared damage (tentacles and injury bond, as well as spectral weapon) was causing quad damage and attacker wretched to be applied twice.

It's possible the buffs to Spectral Weapon are not enough, though some components might go too far (such as the damage scaling at max power). Time to get some more playtesting feedback. I think that giving it enough EV to not be auto-hit by everything will do wonders for its survivability, though AC might actually be a better defense for consistency in play.

It might be preferable to add a fatal/nonfatal parameter to ouch/hurt, so that dealing non-fatal damage isn't as fragile (capping damage at hp-1, even though the amount might change later), but I'm too tired to contemplate adding more parameters to existing code.
Additional Information
Tags No tags attached.
Attached Files ? file icon newskald_spectralweapon_buffs_and_fineff.patch [^] (31,400 bytes) 2013-06-29 13:55 [Show Content]

- Relationships

-  Notes
(0023473)
MarvinPA (developer)
2013-07-17 15:50

Looks like this has been merged.

- Issue History
Date Modified Username Field Change
2013-06-29 13:55 qoala New Issue
2013-06-29 13:55 qoala File Added: newskald_spectralweapon_buffs_and_fineff.patch
2013-07-17 15:50 MarvinPA Note Added: 0023473
2013-07-17 15:50 MarvinPA Status new => resolved
2013-07-17 15:50 MarvinPA Fixed in Branch => 0.13 development branch
2013-07-17 15:50 MarvinPA Resolution open => done
2013-07-17 15:50 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker