Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007278 [DCSS] Upload: Graphics trivial N/A 2013-06-28 13:53 2014-10-25 00:25
Reporter roctavian View Status public  
Assigned To
Priority normal Resolution done  
Status closed   Product Branch 0.13 ancient branch
Summary 0007278: Forest Floor tiles, several miscellaneous monster tiles, one WIP tile
Description I re-colored the old Vestibule of Hell floor since I always liked it, and it makes a great Forest floor, as I subbed it in for the current tiles on my own local build and it looks nice.

L-R: Shadow Fiend, Steam Dragon, Treant, Wiglaf, Shining Eye, Giant Leech, ugly don't use it version of the thorn hunter, part of the previous tile that is salvageable.

Shadow Fiend, Shining Eye, and Giant Leech I all made a while ago, but just never put the finishing touches on, and I needed a break from these damn spell icons. Steam Dragon had that one problem where the black outline/shadow tiles weren't actually black and the auto-outliner made it look weird. I moved Wiglaf's hat a couple pixels and cleaned up some details on his body.

I had a lot of trouble making the thorn hunter work out, and thought maybe I'd just upload the rose head so someone can make a go at the thorn/vine parts of its body. If nobody does, I'll try again later.

Thoughts?
Additional Information
Tags No tags attached.
Attached Files png file icon misc.thorns.png [^] (28,554 bytes) 2013-06-28 13:53


png file icon forest.floor.recolors.png [^] (41,601 bytes) 2013-07-01 17:51


png file icon wisps.png [^] (9,254 bytes) 2013-07-03 10:50


png file icon orkerstar.png [^] (18,568 bytes) 2013-07-03 10:51

- Relationships

-  Notes
(0023341)
mumra (developer)
2013-06-28 20:29

The floor tiles look a bit dark to me - the background is pretty much black on my screen at least. Perhaps if the contrast were adjusted a bit.

The others look pretty cool.
(0023366)
roctavian (developer)
2013-07-01 17:52

Several recolors submitted -- I favor the top one most, but it might still be dark for some folks.
(0023367)
mumra (developer)
2013-07-01 18:54

While I think the lighter version is nice and can probably be used somewhere, it doesn't really say "floor of an enchanted magical forest" to me very strongly. Even the lightest one still has some splodges of black that make it look weirdly swampy; I do wonder if you have your brightness very high / your contrast very low.

Look at some images on a google search for "forest floor": https://www.google.co.uk/search?q=forest+floor&tbm=isch [^]

I see colourful leafy mulch, mossy logs, toadstools, and only occasional grassy areas; and these aren't even magical forests.

So even if this is a minor improvement over the current tiles, I think we could have something much prettier.
(0023380)
roctavian (developer)
2013-07-03 11:34

Well, in the meanwhile, here are a couple of other things:

Wisps.png contains, top row to bottom row, Vapours, Wisps, and Thin Mist tiles. I submitted some less visible versions of the vapours/wisps before and made some corrections so they'd be more visible. They look especially good over darker floors, and luckily you mostly run into those creatures where they stand out.

Orkestar.png has some variations for walls in Orc, which currently shares the same walls as Lair. I would suggest weighting the wall tiles with patches of yellow to show up 15-20% of the time, and floor rubble to show up 5-10%, otherwise we end up with the same problem my ugly Cocytus tiles originally had, all over again.

In any case, I might be able to work on some better forest floors but it might be a while. My only concern with including lots of varied details and visual flavor in floor tiles is that it can harm clarity -- most floors in crawl are dark and often monotone, to make the items/creatures/features on them stand out more. I do think things like leaf mulch, mossy logs, toadstools et al can be included and won't detract from clarity, but it would take me a while and this was a quick just-for-now recolor. Floor tiles are the most difficult kinds of tiles to make for Crawl.

(Not to turn the mantis tracker into a livejournal, but I'll be leaving Istanbul in August to live in India until the spring -- this means I will probably only get online three or four more times before next year. I will try to make as many revisions as possible between now and August, but after that it looks like it'll just be Ontoclasm for a while, and don't work that guy to death while I'm gone)
(0023417)
ontoclasm (developer)
2013-07-07 17:36
edited on: 2013-07-07 18:05

First batch of monsters and orc tiles are in.

As for the others: the basic idea of these forest floors is okay, but the flowers really stand out, due to being bright and having an artificial-looking spread (i.e. they're all individually spaced, with no clumps or bald patches as you would see in real flowers). Maybe just moving the flowers around to break up the patterned look would be enough -- I don't know.

On the wisps etc., I'm not sure about the mist pattern you're using behind them. All the clouds have perfectly flat bottoms and strong outlines, which makes them look a little odd. Maybe something more swirly? Ecch, mist and water and so on are horrible to draw. If only someone would implement the Single Green Cube monster...


Oh, and I sort of edited your thorn hunter, but the brambles they summon need a tile (or tiles), which should probably look like jumbles of those vines. If you'd like to make those it'd be much appreciated.

(0027551)
roctavian (developer)
2014-10-25 00:25

Most of these were added long ago, and the others are otherwise unnecessary.

- Issue History
Date Modified Username Field Change
2013-06-28 13:53 roctavian New Issue
2013-06-28 13:53 roctavian File Added: misc.thorns.png
2013-06-28 20:29 mumra Note Added: 0023341
2013-07-01 17:51 roctavian File Added: forest.floor.recolors.png
2013-07-01 17:52 roctavian Note Added: 0023366
2013-07-01 18:54 mumra Note Added: 0023367
2013-07-03 10:50 roctavian File Added: wisps.png
2013-07-03 10:51 roctavian File Added: orkerstar.png
2013-07-03 11:34 roctavian Note Added: 0023380
2013-07-07 17:36 ontoclasm Note Added: 0023417
2013-07-07 18:05 ontoclasm Note Edited: 0023417
2014-10-25 00:25 roctavian Note Added: 0027551
2014-10-25 00:25 roctavian Status new => closed
2014-10-25 00:25 roctavian Resolution open => done
2014-10-25 00:25 roctavian Fixed in Branch => 0.16 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker