Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007270 [DCSS] Support Request crash always 2013-06-27 03:08 2013-07-01 07:14
Reporter Roshnak View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007270: Truncated Save Chunk upon entering D:17
Description My OgBe is on D:18, and upon taking an upwards staircase to D:17, game crashes, giving the message "truncated save chunk" and prompting to press any key to exit. Multiple attempts give the same result.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0007276closedneil Game crashes while trying to access previously visited level 

-  Notes
(0023326)
neil (administrator)
2013-06-27 05:24
edited on: 2013-06-27 05:43

I've put up a copy of the save for debugging purposes at: http://crawl.akrasiac.org/saves/Roshnak.cs [^]

Version transfers after first entering D:17:
Upgraded the game from 0.13-a0-1887-g8bcbd07 to 0.13-a0-2010-g5476c2e
Upgraded the game from 0.13-a0-2010-g5476c2e to 0.13-a0-2051-ga819e60
Upgraded the game from 0.13-a0-2051-ga819e60 to 0.13-a0-2096-ge3667d1


(0023328)
neil (administrator)
2013-06-27 23:08
edited on: 2013-06-27 23:09

Roshnak: So that you aren't prevented from playing while we try to figure out what happened, I have removed D:17 from your CAO save. It will be regenerated when you enter the level. The ghost that's currently annotated as being on the D:17 is gone, but the annotation will remain.

(0023333)
Roshnak (reporter)
2013-06-28 00:15

Thank you neil, I appreciate your help.
(0023334)
KiloByte (manager)
2013-06-28 00:36

On the low level, the save's internal filesystem is correct, so it's a marshalling/unmarshalling issue.
(0023336)
neil (administrator)
2013-06-28 05:20

Roshnak: I fixed the secondary problem (on entering D:27) caused by the first fix. Try it now.
(0023337)
Roshnak (reporter)
2013-06-28 05:52

Seems to be working fine now, thanks!
(0023362)
neil (administrator)
2013-07-01 06:49

The ultimate cause of the save corruption (an elemental wellspring and an incorrectly-added enum for spectral weapons) is now fixed in trunk (0.13-a0-2175-ga079a5c). The original save loads correctly with this fix.
(0023364)
neil (administrator)
2013-07-01 07:14

(Unmarking as private for the benefit of those with similar problems)

- Issue History
Date Modified Username Field Change
2013-06-27 03:08 Roshnak New Issue
2013-06-27 05:24 neil Note Added: 0023326
2013-06-27 05:43 neil Note Edited: 0023326
2013-06-27 23:08 neil Note Added: 0023328
2013-06-27 23:09 neil Note Edited: 0023328
2013-06-28 00:15 Roshnak Note Added: 0023333
2013-06-28 00:36 KiloByte Note Added: 0023334
2013-06-28 05:20 neil Note Added: 0023336
2013-06-28 05:52 Roshnak Note Added: 0023337
2013-07-01 05:42 neil Relationship added has duplicate 0007276
2013-07-01 06:49 neil Note Added: 0023362
2013-07-01 06:49 neil Status new => resolved
2013-07-01 06:49 neil Fixed in Branch => 0.13 development branch
2013-07-01 06:49 neil Resolution open => done
2013-07-01 06:49 neil Assigned To => neil
2013-07-01 07:14 neil Note Added: 0023364
2013-07-01 07:14 neil View Status private => public


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker