Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007265 [DCSS] Bug Report block have not tried 2013-06-26 11:40 2013-06-26 16:09
Reporter Grandiloquent Gentleman View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007265: don't complain about unambiguous use of pow
Description currently this revision fails to compile ( at least on a mac (10.8) ) because line 1993 of mon-abil in bool _worthy_sacrifice does not cast its arguments

fixable by changing

|| x_chance_in_y(pow(target->hit_dice, 3), 1200));

to

|| x_chance_in_y((int)pow((float)target->hit_dice, 3), 1200));

Have not tried this on other platforms or with clang
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0023310)
Grandiloquent Gentleman (reporter)
2013-06-26 13:41

thanks for fixing, kilobyte!
please close

- Issue History
Date Modified Username Field Change
2013-06-26 11:40 Grandiloquent Gentleman New Issue
2013-06-26 13:41 Grandiloquent Gentleman Note Added: 0023310
2013-06-26 16:09 Medar Status new => resolved
2013-06-26 16:09 Medar Fixed in Branch => 0.13 development branch
2013-06-26 16:09 Medar Resolution open => done
2013-06-26 16:09 Medar Assigned To => Medar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker