Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007241 [DCSS] Source Cleanup trivial N/A 2013-06-21 19:20 2013-06-21 20:07
Reporter reid View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007241: mons_throw still has code for racial ammo
Description Around lines 2284-2293 of throw.cc is code to give monsters accuracy and damage bonuses when using a racial launcher with matching racial ammo. Racial ammo no longer exists.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0023258)
reid (reporter)
2013-06-21 19:34

Though the comment doesn't suggest it, this bit of code also gives +1/+1 to any monster using a non-racial launcher (since all ammo is non-racial), which is pretty weird.
(0023260)
MarvinPA (developer)
2013-06-21 20:07

Fixed, but let's remove racial launchers also (and weapons? (and armour??)).

- Issue History
Date Modified Username Field Change
2013-06-21 19:20 reid New Issue
2013-06-21 19:34 reid Note Added: 0023258
2013-06-21 20:07 MarvinPA Note Added: 0023260
2013-06-21 20:07 MarvinPA Status new => resolved
2013-06-21 20:07 MarvinPA Fixed in Branch => 0.13 development branch
2013-06-21 20:07 MarvinPA Resolution open => done
2013-06-21 20:07 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker