Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007237 [DCSS] Support Request major always 2013-06-21 03:29 2014-03-27 07:15
Reporter blackskull View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0007237: Seeing white splotches instead of Character Tile and Monsters' Tiles
Description Character and monster tiles display as white splotches

Download: stone_soup-0.12.2-win32-installer
Where do I find the "hash"?
Here's the SHA-1 of crawl-tiles.exe 95DE8563913E294935995C3C13815307DB410FBE

Two laptops:
HP 6530b running Windows 7 Pro
Vaio VGN-SZ750N running Windows XP, SP3
Both are dual core processors.

I always see this on the HP. Doesn't matter if the laptop is plugged in or not.

I see the problem on the Vaio when I start the program and the laptop isn't plugged in (It's running on battery). If it is plugged in then tiles display normally. (I don't see any problem)

The problem:
I start up the tiles version of the program. After I select my character & role and the dungeon loads, instead of seeing a troll, human, spriggan, or whatever, I see a white splotch. Then when monsters show up, they are also white splotches. Also, if I save a character, exit the program and restart it then at the bottom, the list of save characters shows white splotches instead of the correct image.

What can I do to fix the problem?

thanks,
Linda
Additional Information
Tags No tags attached.
Attached Files png file icon badxp.png [^] (151,360 bytes) 2013-06-21 12:18
png file icon Saved games.png [^] (53,701 bytes) 2013-06-21 17:40


png file icon Soon after entering the dungeon.png [^] (201,168 bytes) 2013-06-21 17:42
png file icon Setting the Resolution.PNG [^] (54,278 bytes) 2013-06-21 18:34


png file icon Dungeon display OK in Tiny Resolution.png [^] (69,912 bytes) 2013-06-21 18:35


png file icon Dungeon display OK after graphics driver update.PNG [^] (197,135 bytes) 2013-06-21 19:57

- Relationships
has duplicate 0005384resolvedmumra character and monster tiles not displaying 
has duplicate 0006467resolvedmumra Graphic bug/artifact 
related to 0011378confirmed Main window shows white areas where tiles should be (on Virtual Box) 

-  Notes
(0023247)
mumra (developer)
2013-06-21 04:15

* Have you installed the latest versions of your graphics drivers?
* What graphics cards / chips are in the laptops? (Make and manufacturer)
* Could you also attach screenshots of the problem from both computers

The fact that the Vaio gets this problem only on battery mode suggests to me it's *something* to do with hardware acceleration, since laptops sometimes switch to a high performance mode when connected to power, sometimes even to a different graphics chip (maybe not so commonly on older laptops, but still this is a clue).

One tactic you could try is changing your graphics performance settings - disabling hardware acceleration if you can find that option. If I have information about the graphics vendors I might be able to make more detailed suggestions.
(0023249)
KiloByte (manager)
2013-06-21 12:18

If by "splotch" you mean a rectangle, then this is what I see practically everywhere on Windows save for direct hardware acceleration on one of "newest and greatest" graphics cards of the three main brands. This might be what 99% players use, but we're not a gaming company to not care the slightest about portability.

It appears to have recently regressed, though: before, "only" all monsters/players were turned to white rectangles, it's pretty much all tiles now.
(0023251)
mumra (developer)
2013-06-21 17:12

My old laptop certainly ran fine and it definitely didn't have a "newest and greatest" graphics card (although unfortunately it's not in the same city as me right now so I can't test the latest builds).

One possibility: we have rather a lot more tiles than we used to, perhaps we're overflowing the graphics memory trying to load the whole tileset?
(0023253)
mumra (developer)
2013-06-21 17:22

Some further sleuthing: on an old ticket 0005384 I just found, the monster tilesheet has gone white but the walls are fine. The wall tilesheet is now much bigger with a ton of recolourings of base tiles.

My theory here is that the big tilesheets are now too much for some graphics drivers/cards to load into memory at once.

So two possible approaches present themselves (not mutually exclusive):

1. Split the tilesheets up more; how this split would work I'm not sure but for memory management purposes it would seem reasonable to have per-branch sheets for branch-native walls, floors, monsters; and then global sheets for stuff used everywhere. Some might need arbitrarily splitting up further but first we need to figure out exactly what size of tilesheet is triggering the bug.

2. Implement tile recolouring in a different way. Pre-rendering all these tile variations into sprite sheets is ok for just the odd case but now we have nearly every wall/floor tile recoloured into at least every fundamental colour it's more of a problem. We end up with huge tilesheets, and the tile definition files become much less manageable. It makes more sense to do this type of recolouring in real time; there could be a performance hit but I think this is worth it for a working game. And there could be performance gains from having smaller tilesheets in the first place. Doing this we are also less limited in having to specify all colour variations beforehand, could render interesting new effects with the extra flexibility.
(0023255)
mumra (developer)
2013-06-21 17:26

0006467 has many other duplicates linked
(0023256)
blackskull (reporter)
2013-06-21 18:00

I have attached 2 images - the "saved games" list, and what the dungeon looks like after I started a new game (as Merlin the Merfolk Transmuter) and got a few monsters waiting for me around the corner (almost all the monsters are behind locked gates or transparent walls, thankfully! :-)

I am using the HP Compaq laptop in these screenshots.

Please let me know how I can a) provide more information about my system configuration (click here, type that, point to this, take a screenshot of xyz), and also about how I can improve, for example, my drivers.

I am running Windows 7 Professional, 32-bit.
I have 4GB of RAM (only 3GB can be used on 32-bit system)

The processors for the HP from the Computer properties page:

Intel(R) Core(TM)2 Duo CPU P8600 @ 2.40GHz 2.40 GHz

Installed memory (RAM): 4.00 GB (2.90 GB usable)

In Device Manager:
Display adapters says
    Mobile Intel($) 45 Express Chipset Family (Microsoft Corporation - WDDM 1.1)

Monitors says
    Generic PnP Monitor

I'm not sure if this is a bug or if I need to improve something on this computer, so I entered my original report as a Service Request rather than a bug report.

THANKS!
Linda
(0023257)
blackskull (reporter)
2013-06-21 18:33

I have found a setting on the HP laptop where the graphic tiles show instead of white splotches. It's very tiny - 640 by something. Hard to see, but at least it works.

Maybe I need to allocate more memory to graphics processing? How do I do that?

I am attaching 2 screen images - the first is the settings screen (Windows 7), the second is what the dungeon looked like with those settings.
(0023259)
blackskull (reporter)
2013-06-21 19:54

I figured out how to find, download, install driver for Graphics from HP site. After installing the driver and restarting crawl, the "Save games" section and the dungeon itself look fine.

The only weird thing is that when I use the setting to expand the graphics area too the whole physical screen, it looks the best, but the new driver software is telling me the best resolution for this display is 1024 x 768 instead of 1280 x 800.

I'm not sure why that is, but I'm sure it has nothing to do with the Crawl software, so my particular issue here is solved.

thanks!
Linda

- Issue History
Date Modified Username Field Change
2013-06-21 03:29 blackskull New Issue
2013-06-21 04:15 mumra Note Added: 0023247
2013-06-21 12:18 KiloByte Note Added: 0023249
2013-06-21 12:18 KiloByte File Added: badxp.png
2013-06-21 17:12 mumra Note Added: 0023251
2013-06-21 17:13 mumra Relationship added has duplicate 0005384
2013-06-21 17:22 mumra Note Added: 0023253
2013-06-21 17:24 mumra Relationship added has duplicate 0006467
2013-06-21 17:26 mumra Note Added: 0023255
2013-06-21 17:40 blackskull File Added: Saved games.png
2013-06-21 17:42 blackskull File Added: Soon after entering the dungeon.png
2013-06-21 18:00 blackskull Note Added: 0023256
2013-06-21 18:01 blackskull Issue Monitored: blackskull
2013-06-21 18:33 blackskull Note Added: 0023257
2013-06-21 18:34 blackskull File Added: Setting the Resolution.PNG
2013-06-21 18:35 blackskull File Added: Dungeon display OK in Tiny Resolution.png
2013-06-21 19:54 blackskull Note Added: 0023259
2013-06-21 19:57 blackskull File Added: Dungeon display OK after graphics driver update.PNG
2014-03-27 07:15 MarvinPA Status new => resolved
2014-03-27 07:15 MarvinPA Fixed in Branch => 0.14 development branch
2014-03-27 07:15 MarvinPA Resolution open => done
2014-03-27 07:15 MarvinPA Assigned To => MarvinPA
2018-02-06 15:36 advil Relationship added related to 0011378


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker