Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007180 [DCSS] Bug Report minor sometimes 2013-06-08 16:51 2014-04-30 18:33
Reporter geekosaur View Status public  
Assigned To neil
Priority normal Resolution done  
Status closed   Product Branch 0.13 ancient branch
Summary 0007180: Beogh conversion information leak before orc priest comes into LOS
Description Backed-up save for Duph on CSZO: http://dobrazupa.org/saves/Duph-crawl-git-99810c380d-130608-1445.tar.bz2 [^]
this is from some moves after the priest came into LOS; if I reproduce this again later I'll save and backup when it happens.

I moved into an area which had a visible orc but no visible orc priests, and got the "(press a Y to convert to Beogh)" message. I did *not* get the "Beogh" HUD status light immediately, just the "press a Y". 3 moves later an orc priest came into LOS.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0023136)
neil (administrator)
2013-06-10 02:48

Fixed in trunk (0.13-a0-1552-g7f8ecaa), thanks! It was only checking whether the priest was in LOS radius and you were not invisible: it didn't actually check for line of sight.

I have cleaned up both the status light and the preaching messages to use the same check. Now they both check: are you visible to the priest, can you see the priest (visibility + line of sight), and is the priest unsilenced. The status light also checks whether you are silenced (since you cannot use the ability if you are).

- Issue History
Date Modified Username Field Change
2013-06-08 16:51 geekosaur New Issue
2013-06-10 02:48 neil Note Added: 0023136
2013-06-10 02:48 neil Status new => resolved
2013-06-10 02:48 neil Fixed in Branch => 0.13 development branch
2013-06-10 02:48 neil Resolution open => done
2013-06-10 02:48 neil Assigned To => neil
2014-04-30 18:33 geekosaur Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker