Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007179 [DCSS] Bug Report minor have not tried 2013-06-08 09:59 2013-06-09 04:18
Reporter magicpoints View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007179: Forest unique spawned twice
Description On my last game, Pan spawned twice as I was exploring the new Enchanted Forest branch. He appeared in Forest:2, was killed, and then reappeared in Forest:5 in the ending vault. The morgue file from that game:

http://dobrazupa.org/morgue/magicpoints/morgue-magicpoints-20130608-072530.txt [^]

The relevant bits:

 63088 | Forest:2 | Noticed Pan
 63092 | Forest:2 | mp: ==> no see invis on pan, huh?
 63096 | Forest:2 | Killed Pan

 67304 | Forest:5 | Noticed Pan
 67307 | Forest:5 | mp: ==> hey
 67312 | Forest:5 | Killed Pan

Vault maps used:
Forest:2: tomb_entry_shell_bobbens, uniq_pan, uniq_sojobo, uniq_frederick
Forest:5: grunt_forest_end_winery, uniq_enchantress
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0023122)
sgrunt (administrator)
2013-06-09 04:18

This was being caused by a subtle bug in Lua you.uniques which only crops up if a unique name shares a branch abbreviation. As of 0.13-a0-1536-gedae9ec, it now checks for an exact match for the unique name instead of checking other possibilities.

- Issue History
Date Modified Username Field Change
2013-06-08 09:59 magicpoints New Issue
2013-06-08 13:59 Medar Category Documentation => Bug Report
2013-06-09 04:18 sgrunt Note Added: 0023122
2013-06-09 04:18 sgrunt Assigned To => sgrunt
2013-06-09 04:18 sgrunt Status new => resolved
2013-06-09 04:18 sgrunt Fixed in Branch => 0.13 development branch
2013-06-09 04:18 sgrunt Resolution open => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker