Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007136 [DCSS] Bug Report major have not tried 2013-06-02 12:24 2013-06-02 13:53
Reporter madreisz View Status public  
Assigned To KiloByte
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007136: Blinking with a lava orc (?) can place them in deep water
Description This bug was not encountered by me --- I only observed it after the fact by watching it on the termcast footv.

4thArraOfDagoon drowned after blinking as a lava orc (with the blink placing him directly into deep water) on coc:1, this can be replayed through termcast with the query !lg 4thArraOfDagon lofe coc:1 -tv.

Here the morgue of the death: http://dobrazupa.org/morgue/4thArraOfDagon/morgue-4thArraOfDagon-20130602-101110.txt [^]
Additional Information
Tags No tags attached.
Attached Files ? file icon lo_blink_deep_water.patch [^] (2,251 bytes) 2013-06-02 13:15 [Show Content]

- Relationships

-  Notes
(0023015)
qoala (reporter)
2013-06-02 12:33

teleport.cc:random_near_space checks what is the lowest DNGN_ enum which is safe, then assumes any feature above or equal is safe. This previously worked because the threats of DNGN_LAVA > DNGN_DEEP_WATER > DNGN_MINWALK were strictly ordered.

If the player can travel in lava, it assumes the player can also travel in deep water. Lava orcs break that assumption.

The code probably now needs to check individually for DNGN_LAVA and DNGN_DEEP_WATER.
(0023016)
qoala (reporter)
2013-06-02 13:31

I've attached a patch. Also, 7137 should be merged with this one.
(0023018)
KiloByte (manager)
2013-06-02 13:53

Patch applied, thanks!

- Issue History
Date Modified Username Field Change
2013-06-02 12:24 madreisz New Issue
2013-06-02 12:33 qoala Note Added: 0023015
2013-06-02 13:15 qoala File Added: lo_blink_deep_water.patch
2013-06-02 13:31 qoala Note Added: 0023016
2013-06-02 13:53 KiloByte Note Added: 0023018
2013-06-02 13:53 KiloByte Status new => resolved
2013-06-02 13:53 KiloByte Fixed in Branch => 0.13 development branch
2013-06-02 13:53 KiloByte Resolution open => done
2013-06-02 13:53 KiloByte Assigned To => KiloByte


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker