Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007130 [DCSS] Bug Report minor have not tried 2013-06-01 21:42 2013-06-04 19:29
Reporter timpakay View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007130: Lava orc loses stoneskin sometimes
Description Various situations cause LO stoneskin to be either missing or not displayed. Original report follows. -neil

I was a bit unsure if I was supposed to report this as a bug or a change, since I think it makes sense happening I decided to report it as a change.

I just noticed on my current lava orc char that I lost 2 ac after getting the "slimy green scales +2 AC"-mutation. I think it makes perfect sense that my skin changes from the stoneskin to scales and that I loose that bonus, on the other hand I dislike that this comes from drinking a potion of beneficial mutations.

So my two cents are either lava orcs do not gain scale mutations from potions of benficial mutations, since the effect is not benificial, or the stoneskin bonus stay after getting the bonus (think of it like the scales being of stone also).

Or just ignore me :)
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0023004)
timpakay (reporter)
2013-06-01 21:47

I just noticed that you get back the stoneskin bonus if it melts and then comes back, so the loss is only temporary. And that makes this a bug instead.
(0023047)
neil (administrator)
2013-06-04 09:14

Other problems: you don't start with stoneskin, and stoneskin can expire (it has a duration of 500 and ticks down normally). There may also be problems with transformations and maybe with the Helm card; I haven't had a chance to test those yet.
(0023050)
neil (administrator)
2013-06-04 19:29

Fixed in trunk (0.13-a0-1432-g8b5eb89), thanks! LO stoneskin is no longer a duration, so can't expire, be dispelled, etc.

- Issue History
Date Modified Username Field Change
2013-06-01 21:42 timpakay New Issue
2013-06-01 21:47 timpakay Note Added: 0023004
2013-06-04 08:21 neil Summary Lava orc looses stoneskin bonus when gaining ac-mutation (change beneficial mutation potions) => Lava orc loses stoneskin sometimes
2013-06-04 08:21 neil Description Updated
2013-06-04 08:23 neil Status new => confirmed
2013-06-04 09:04 neil Category Patches => Bug Report
2013-06-04 09:14 neil Note Added: 0023047
2013-06-04 18:22 neil Status confirmed => assigned
2013-06-04 18:22 neil Assigned To => neil
2013-06-04 19:29 neil Note Added: 0023050
2013-06-04 19:29 neil Status assigned => resolved
2013-06-04 19:29 neil Fixed in Branch => 0.13 development branch
2013-06-04 19:29 neil Resolution open => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker