Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007124 [DCSS] Bug Report minor always 2013-06-01 00:20 2013-06-01 22:49
Reporter josh View Status public  
Assigned To mumra
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007124: Lava Orc at maximum temperature may benefit from manuals but may not start reading new ones
Description When a Lava Orc is at maximum temperature, they have the special ability "You are too hot to use scrolls or read books.", and hitting 'r' says "You'd burn any scroll you tried to read!". However, if you had already started reading a manual before reaching that temperature, you will continue to train skills at that increased rate, benefiting from the manual that you can't read.

Either Lava Orcs should stop benefiting from manuals at higher temperatures, or (preferred) they should be able to read or stop reading manuals at high temperatures. Potential additional flavor text for manuals: "Owing to the high propensity for training accidents, this manual is extremely resilient to damage, including by high temperatures."

Unrelated to this, perhaps Lava Orcs should get +N to Fire Magic and -N to Ice Magic while hot, for values of N around 1-2 for increasing points in the temperature scale?
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0007116resolvedmumra Hot lava orcs can't learn spells from Vehumet 

-  Notes
(0022987)
mumra (developer)
2013-06-01 00:21

I think the solution is the same as 0007116, don't prevent LO's reading books.
(0023006)
mumra (developer)
2013-06-01 22:49

Fixed in trunk, Lava Orcs are no longer prevented from reading books at any temperature, since this was an annoyance at best with no gameplay consequences.

- Issue History
Date Modified Username Field Change
2013-06-01 00:20 josh New Issue
2013-06-01 00:21 mumra Relationship added related to 0007116
2013-06-01 00:21 mumra Note Added: 0022987
2013-06-01 22:49 mumra Note Added: 0023006
2013-06-01 22:49 mumra Status new => resolved
2013-06-01 22:49 mumra Fixed in Branch => 0.13 development branch
2013-06-01 22:49 mumra Resolution open => done
2013-06-01 22:49 mumra Assigned To => mumra


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker