Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007116 [DCSS] Bug Report minor have not tried 2013-05-31 11:09 2013-06-01 22:49
Reporter nubinia View Status public  
Assigned To mumra
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007116: Hot lava orcs can't learn spells from Vehumet
Description as 'M' assumes you are learning from a book.


Starting Dungeon Crawl Stone Soup fddfa6a...
          ........... ... ThursdayNext the Firebug
         #............ .... Lava Orc of Vehumet *.....
        ##....................... Health: 19/38 ============------------
       .......................... Magic: 4/9 ==========--------------
       ..................#####... Temperature: ========================
       .........<........#####... AC: 3 Str: 11
      .........<.<.......#####... EV: 12 Int: 16
      ...................#####... SH: 0 Dex: 11
      ...................#####... XL: 5 Next: 59% Place: Dungeon:5
      ........................... Gold: 163 Time: 6035.6 (1.0)
      ####......@...5............ Wp: a) dwarf hand axe
       ###....................... Qv: -) Nothing quivered
       ###....................... Hungry
       ###....................... 5 crimson imp
       ###.......#####...........
       ..........#####...........
      ...........#####...........
      ...........#####...........
      ..........%#####...........
       ..........................
       ..........................
 Vehumet accepts your kill.
 You can now gain magical power from killing.
 Vehumet offers you knowledge of Sandblast.
 You feel sick.
_You feel better.
_You'd burn any book you tried to read!
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0007124resolvedmumra Lava Orc at maximum temperature may benefit from manuals but may not start reading new ones 

-  Notes
(0022959)
nubinia (reporter)
2013-05-31 13:30

And they should be able to learn from artefact books too, as they don't catch fire :)
(0022960)
mumra (developer)
2013-05-31 13:34

Apparently bat form will also prevent Vehumet memorisation which I don't see a reason for. The other cases checked in can_learn_spell seem reasonable either for Vehumet or book reading.
(0022961)
mumra (developer)
2013-05-31 13:36

It's slightly difficult to special case the check to allow Vehumet spells only to be memorised at high temperature. But I'm not sure there's a really good reason to disallow book memorisation other than flavour, it doesn't achieve anything gameplay-wise except forcing you to wait until you've cooled down. Maybe we should just remove that check?
(0022979)
MarvinPA (developer)
2013-05-31 19:05
edited on: 2013-05-31 19:06

IIRC the only reason it was ever disabled was so that going to max temperature could just block "r" entirely (since that lists scrolls and books, and the point is to disable scrolls), but yeah, it's just annoying that way, entering the read menu and reading/memorising from books should be allowed as normal.

(0023007)
mumra (developer)
2013-06-01 22:49

Fixed in trunk, Lava Orcs are no longer prevented from reading books at any temperature, since this was an annoyance at best with no gameplay consequences.

- Issue History
Date Modified Username Field Change
2013-05-31 11:09 nubinia New Issue
2013-05-31 13:30 nubinia Note Added: 0022959
2013-05-31 13:34 mumra Note Added: 0022960
2013-05-31 13:36 mumra Note Added: 0022961
2013-05-31 19:05 MarvinPA Note Added: 0022979
2013-05-31 19:05 MarvinPA Note Edited: 0022979
2013-05-31 19:06 MarvinPA Note Edited: 0022979
2013-06-01 00:21 mumra Relationship added related to 0007124
2013-06-01 22:49 mumra Note Added: 0023007
2013-06-01 22:49 mumra Status new => resolved
2013-06-01 22:49 mumra Fixed in Branch => 0.13 development branch
2013-06-01 22:49 mumra Resolution open => done
2013-06-01 22:49 mumra Assigned To => mumra


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker