Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007071 [DCSS] Bug Report major have not tried 2013-05-21 17:42 2015-12-24 20:52
Reporter mumra View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007071: Numerous issues with Targetting, Tracers, Clouds and Breaths
Description There are a large number of bug reports targetting, tracers, clouds, etc. This area of the code could perhaps do with a general overhaul. I am triaging all such bugs under this one ticket to make it easier to keep track of them all.

I'll also include the "targeting" spelling for anyone searching Mantis.
Additional Information
Tags targeting, targetting
Attached Files

- Relationships
parent of 0005892closedneil Crash on chaos bouncing 
parent of 0005941resolvedwheals Targeting with lightning bolt can fail to highlight monsters 
parent of 0004332resolvedwheals Buggy targeting spell 
parent of 0001531resolvedwheals No indication that you're sure. 
parent of 0001558resolvedwheals Firing through plants 
parent of 0001905new out of range screen flash isn't useful 
parent of 0001054resolvedwheals Wrong message when targeting monsters behind glass 
parent of 0004507resolvedwheals Poisonous Cloud targeting rendering bug 
parent of 0002750resolveddoy Breath targetting bugs 
parent of 0000620resolvedwheals Conjure flame text displays 
parent of 0002603resolvedwheals Spell/ability miscast/failure targeting inconsistency 
parent of 0006280closedwheals Self-targeting with tome of destruction allows 0-time cancel 
parent of 0006968resolvedwheals auto-targeting issue with ensorcelled hibernation etc 
parent of 0007091resolvedwheals Bad default targeting with poison spells 
parent of 0007092closedwheals Confirmation when no targets can be hit is more annoying than useful with cloud spells 
parent of 0007093closedwheals Spell targeting can leak information about unseen monsters 
parent of 0003916resolvedPleasingFungus door mimics change spell pathing 
parent of 0006079resolvedwheals Pacification automatically tries to target monsters on the other side of glass walls. 
parent of 0005226closed Stasis lets you waste haste 
parent of 0007785closedwheals Multi-Zap Indicators in Tiles 
parent of 0007244confirmed Could we get a warning if using an evocable has a chance to piss off TSO? 
parent of 0007540resolvedwheals No warning for rubble from Stone of Tremors turning permanent allies hostile 
parent of 0009391resolvedwheals Hexes don't check for immunity while targetting properly. 
Not all the children of this issue are yet resolved or closed.

-  Notes
(0022765)
KiloByte (manager)
2013-05-21 18:11

Beh, such a large part of the word spells it with one -t- that sticking to the .au spelling might be a lost cause.
(0022767)
mumra (developer)
2013-05-21 19:39

I only meant I was including both spellings in the ticket description, so anyone searching for either spelling would find this issue.

I grew up believing 'tt' was the British spelling but apparently even that's wrong.

Anyway it's damn inconsistent of language, every other word that ends the same way uses two 't's.
(0024560)
neil (administrator)
2013-11-30 19:46

Added child issues 0005226 (wand of haste doesn't ask for confirmation on immune monsters/players), 0007785 (display multi-zapping in tiles), and 0007244 (evocables don't give stop-attack prompts).
(0030077)
wheals (administrator)
2015-12-24 20:52

Since most of the issues are resolved or assigned, I'm going to go ahead and close this one.

- Issue History
Date Modified Username Field Change
2013-05-21 17:42 mumra New Issue
2013-05-21 17:43 mumra Summary Targetting and Tracer issues => Numerous issues with Targetting, Tracers, Clouds and Breaths
2013-05-21 17:43 mumra Description Updated
2013-05-21 17:44 mumra Relationship added parent of 0005892
2013-05-21 17:44 mumra Relationship added parent of 0005941
2013-05-21 18:03 mumra Relationship added parent of 0004332
2013-05-21 18:03 mumra Relationship added parent of 0001531
2013-05-21 18:04 mumra Tag Attached: targeting
2013-05-21 18:04 mumra Tag Attached: targetting
2013-05-21 18:05 mumra Relationship added parent of 0001558
2013-05-21 18:11 KiloByte Note Added: 0022765
2013-05-21 18:32 mumra Relationship added parent of 0001905
2013-05-21 18:39 mumra Relationship added parent of 0001054
2013-05-21 18:40 mumra Relationship added parent of 0004507
2013-05-21 18:40 mumra Relationship added parent of 0002750
2013-05-21 18:41 mumra Relationship added parent of 0000620
2013-05-21 19:34 mumra Relationship added parent of 0002603
2013-05-21 19:39 mumra Note Added: 0022767
2013-05-21 20:02 mumra Relationship added parent of 0006280
2013-05-21 20:03 mumra Relationship added parent of 0006968
2013-05-27 21:14 Medar Relationship added parent of 0007091
2013-05-27 21:23 Medar Relationship added parent of 0007092
2013-05-27 21:39 Medar Relationship added parent of 0007093
2013-07-06 07:29 Medar Relationship added parent of 0003916
2013-07-06 07:39 Medar Relationship added parent of 0006079
2013-11-30 19:43 neil Relationship added parent of 0005226
2013-11-30 19:44 neil Relationship added parent of 0007785
2013-11-30 19:44 neil Relationship added parent of 0007244
2013-11-30 19:46 neil Note Added: 0024560
2014-03-10 08:26 Medar Relationship added parent of 0007540
2014-09-03 19:18 evktalo Issue Monitored: evktalo
2015-01-12 03:50 neil Relationship added parent of 0009391
2015-12-24 20:52 wheals Note Added: 0030077
2015-12-24 20:52 wheals Status new => resolved
2015-12-24 20:52 wheals Fixed in Branch => 0.18 development branch
2015-12-24 20:52 wheals Resolution open => done
2015-12-24 20:52 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker