Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007063 [DCSS] Bug Report block have not tried 2013-05-20 17:30 2013-05-23 23:56
Reporter Dorian View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0007063: Random Teleport in lava Pit (Abyss)
Description You are suddenly pulled into a different region of the Abyss!
You fall into the lava!
The lava burns you to a cinder!
You die...

I was roaming in the Abyss, looking for the rune. I was not flying.
morgue:
http://dobrazupa.org/morgue/Dorian/morgue-Dorian-20130520-132151.txt [^]
Additional Information
Tags abyss
Attached Files

- Relationships
has duplicate 0007072resolvedMarvinPA Abyss Teleport Leads To Dunk In Lava 
has duplicate 0007077resolved Abyss Teleport Leads To Drown 

-  Notes
(0022719)
neil (administrator)
2013-05-21 05:31

Maybe the line "grd(you.pos()) = DNGN_FLOOR;" in _abyss_generate_new_area needs to do something with the sample queue to ensure that the feature doesn't get replaced next turn?
(0022794)
sgrunt (administrator)
2013-05-23 23:56

Some investigation on my part revealed that this was being caused by abyssal vault placements; the terrain update code was being fired long before any of the abyss.cc checks for bad terrain at the player position was being fired.

0.13-a0-877-gb72fcf6 sets the Generating_Level flag during abyssal vault placements so that the hostile terrain checks fire properly afterwards; thus, this really should no longer happen.

I don't yet know if this is going to cause side effects, but if it doesn't, I hope to cherry-pick the change to 0.12.

- Issue History
Date Modified Username Field Change
2013-05-20 17:30 Dorian New Issue
2013-05-20 19:19 Dorian Tag Attached: AI
2013-05-20 19:19 Dorian Tag Detached: AI
2013-05-20 19:19 Dorian Tag Attached: abyss
2013-05-21 05:31 neil Note Added: 0022719
2013-05-22 20:23 MarvinPA Relationship added has duplicate 0007072
2013-05-23 12:07 KiloByte Relationship added has duplicate 0007077
2013-05-23 23:56 sgrunt Note Added: 0022794
2013-05-23 23:56 sgrunt Assigned To => sgrunt
2013-05-23 23:56 sgrunt Status new => resolved
2013-05-23 23:56 sgrunt Resolution open => done
2013-05-23 23:56 sgrunt Fixed in Branch => 0.13 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker