Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007060 [DCSS] Bug Report minor have not tried 2013-05-19 06:51 2013-10-29 14:48
Reporter LexAckson View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status closed   Product Branch 0.12 ancient branch
Summary 0007060: Chaos cloud berserk triggers chei penance
Description I was in the abyss and an apocalypse crab breathed chaos clouds. The clouds made me go berserk and chei penance triggered.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0022703)
sgrunt (administrator)
2013-05-19 17:59

I've poked a bit at this, and made the following observations:

1) It's not the cloud that causes it - it's getting directly hit by the blast of chaos.

2) The reason penance is invoked is because the relevant code uses potion_effect() without specifying that it's not a potion and that the effect isn't known.

3) Penance also occurs if the direct chaos blast hastes the player, for exactly the same reasons.

I made a naive attempt to fix it earlier without success, but I might tinker with it further.
(0022723)
sgrunt (administrator)
2013-05-21 05:51

Fixed in 0.13-a0-816-gb11031e. Thanks!
(0024270)
LexAckson (reporter)
2013-10-29 14:48

Keep up the good work

- Issue History
Date Modified Username Field Change
2013-05-19 06:51 LexAckson New Issue
2013-05-19 17:59 sgrunt Note Added: 0022703
2013-05-21 05:51 sgrunt Note Added: 0022723
2013-05-21 05:51 sgrunt Assigned To => sgrunt
2013-05-21 05:51 sgrunt Status new => resolved
2013-05-21 05:51 sgrunt Resolution open => done
2013-05-21 05:51 sgrunt Fixed in Branch => 0.13 development branch
2013-10-29 14:48 LexAckson Note Added: 0024270
2013-10-29 14:48 LexAckson Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker