Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007012 [DCSS] Bug Report major always 2013-05-04 22:52 2015-07-25 02:46
Reporter minmay View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status closed   Product Branch 0.13 ancient branch
Summary 0007012: Ridiculous zombie/skeleton/simulacrum generation
Description Commit 630cb13277100dd2dfbdd6881b64086b5580405f changed zombie generation to use depth "correctly." This has made tougher undead generate much, much earlier: hill giant zombies have 75 kills in 0.13-a, which has been around for only a few weeks. They had 91 in 0.12-a which existed for around 8 months, and numbers for 0.10 and 0.11 stable are very similar.

I consider this bad enough to be a severe bug because zombies are among the worst enemies in the game - nearly all of them are slower than you and they have a lot of HP, so there is rarely any danger but they take a very large amount of real time to fight. Furthermore, this is greatly increasing the amount of experience available - an ogre zombie on D:2 is easy to kill unless you are a naga, but likely gives more XP by itself than all of D:1 put together. This seems to throw early-game balance off by quite a bit.

My preferred solution would be to remove zombies, skeletons, and simulacra from random generation entirely since they are such boring enemies, but at the very least, please use a shallower base depth.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0022561)
sgrunt (administrator)
2013-05-07 00:59

Regardless of the random generation or not, there are enough monsters and vaults that place zombies as part of the band / map that having ridiculous monsters generate as a result of this tweak is undesirable.

I've adjusted the zombie selector to scale the out-of-depthness as a function of current dungeon depth (0.13-a0-624-gd04699d), which should help address some of the ridiculousness on the early game side of things (where this is going to matter the most).

I'm leaving this open so we can decide on the fate of undead monster generation in main D, but I certainly wouldn't object to their removal there (they place enough there as part of vaults, bands, etc. already).
(0028607)
PleasingFungus (administrator)
2015-03-06 07:19

Zombie generation was changed to remove slow zombies from D, which makes them a lot more tolerable.

...that probably should have been a different ticket; the original issue was solved nearly two years ago...

- Issue History
Date Modified Username Field Change
2013-05-04 22:52 minmay New Issue
2013-05-07 00:59 sgrunt Note Added: 0022561
2015-03-06 07:19 PleasingFungus Note Added: 0028607
2015-03-06 07:19 PleasingFungus Status new => resolved
2015-03-06 07:19 PleasingFungus Fixed in Branch => 0.16 pre-release branch
2015-03-06 07:19 PleasingFungus Resolution open => done
2015-03-06 07:19 PleasingFungus Assigned To => PleasingFungus
2015-07-25 02:46 minmay Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker