Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007006 [DCSS] Bug Report crash sometimes 2013-05-03 20:52 2013-05-05 04:59
Reporter pixnaps View Status public  
Assigned To KiloByte
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0007006: Dazzling spray (after battlesphere) causes crash
Description See attached save game. Cast battlesphere, followed by a dazzling spray on the bees, and the game crashes.
Additional Information
Tags No tags attached.
Attached Files ? file icon Rikar.cs [^] (298,463 bytes) 2013-05-03 20:52
txt file icon crash-Chael-20130504-001922.txt [^] (44,630 bytes) 2013-05-04 09:12 [Show Content]
? file icon Chael.cs [^] (314,248 bytes) 2013-05-04 09:14

- Relationships

-  Notes
(0022543)
rickstrongo (reporter)
2013-05-04 09:12

I've encountered the same bug. Casting dazzling spray while battlesphere is active causes the game to crash
(0022544)
Kabixx (reporter)
2013-05-04 13:36

The same thing happens to me when I you use Orb of Destruction after dazzling spray. Playing Tile Version
(0022545)
Itholyth (reporter)
2013-05-04 16:49

Same here. Tile version, casting the dazzling spray with the sphere out makes a crash.
(0022548)
abc (reporter)
2013-05-04 20:24

Tile version, casting the Mephitic Cloud with active battlesphere makes a crash.
(0022550)
V38 (reporter)
2013-05-04 22:51

Appear to have encountered the same issue, playing online in console, thought I'd share the crash.txt's in case it's any use:
http://crawl.akrasiac.org/rawdata/v38m2y69t/crash-v38m2y69t-20130504-175229.txt [^]
http://crawl.akrasiac.org/rawdata/v38m2y69t/crash-v38m2y69t-20130504-175229.txt [^]
http://crawl.akrasiac.org/rawdata/v38m2y69t/crash-v38m2y69t-20130504-202452.txt [^]
(0022552)
KiloByte (manager)
2013-05-05 04:59

v38: this crash is Windows only. A fix caused a regression, though, but that was in trunk.

DracoOmega fixed it a few hours ago, and since this bug is a high profile one, I've just pushed a point release, 0.12.1.

- Issue History
Date Modified Username Field Change
2013-05-03 20:52 pixnaps New Issue
2013-05-03 20:52 pixnaps File Added: Rikar.cs
2013-05-04 08:38 rickstrongo Issue Monitored: rickstrongo
2013-05-04 09:12 rickstrongo File Added: crash-Chael-20130504-001922.txt
2013-05-04 09:12 rickstrongo Note Added: 0022543
2013-05-04 09:14 rickstrongo File Added: Chael.cs
2013-05-04 13:36 Kabixx Note Added: 0022544
2013-05-04 16:49 Itholyth Note Added: 0022545
2013-05-04 20:24 abc Note Added: 0022548
2013-05-04 22:51 V38 Note Added: 0022550
2013-05-05 04:59 KiloByte Note Added: 0022552
2013-05-05 04:59 KiloByte Status new => resolved
2013-05-05 04:59 KiloByte Fixed in Branch => 0.13 development branch
2013-05-05 04:59 KiloByte Resolution open => done
2013-05-05 04:59 KiloByte Assigned To => KiloByte


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker