Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007005 [DCSS] Patches minor have not tried 2013-05-03 20:08 2014-04-29 02:29
Reporter Annonith View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0007005: Trove eats an item when such item caused banishment to Abyss while unwielding it
Description - During one of my games portal to Trove showed up that required demon blade
- I found demon blade with distortion brand, wielded it to enchant
- Went to the Trove, and while still wielding the sword, I gave it to the Trove
- While the Trove took the sword, its distortion brand caused a banishment to Abyss
- When I got out of the Abyss, the portal to Trove was already closed
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Make-troves-not-accept-equipped-items.patch [^] (1,775 bytes) 2013-05-15 20:19 [Show Content]
? file icon 0001-Forbid-troves-from-accepting-equipped-items.patchNEW [^] (16,344 bytes) 2013-05-26 22:55
? file icon 0002-Make-note-of-the-items-paid-shown-to-enter-troves.patchNEW [^] (7,233 bytes) 2013-05-26 22:55

- Relationships
related to 0007694new Trove eats items due to teleportitis 

-  Notes
(0022536)
mumra (developer)
2013-05-03 20:24

Maybe we should just print a "you must unwield that first" message if trying to pay for a trove with a wielded item? (Or otherwise equipped I guess)
(0022537)
Galefury (updater)
2013-05-04 00:30

That would also protect people from accidentally sacrificing something they are using.
(0022673)
blackcustard (reporter)
2013-05-15 20:20
edited on: 2013-05-27 17:37

EDIT: Patch attached. Apply the 2nd and 3rd patch. Do not apply the 1st. I'm sorry for the confusion.

Thank you mumra for deleting the bad versions. Again, do not apply the 1st patch.

(0022886)
mumra (developer)
2013-05-27 17:17

I deleted the 2nd and 3rd patches to avoid confusion. So I think all three attached patches need applying now.
(0025939)
MarvinPA (developer)
2014-04-29 02:28

Finally got around to looking at/pushing these, thanks for the patches!

- Issue History
Date Modified Username Field Change
2013-05-03 20:08 Annonith New Issue
2013-05-03 20:24 mumra Note Added: 0022536
2013-05-04 00:30 Galefury Note Added: 0022537
2013-05-15 20:19 blackcustard File Added: 0001-Make-troves-not-accept-equipped-items.patch
2013-05-15 20:20 blackcustard Note Added: 0022673
2013-05-26 22:34 blackcustard File Added: 0001-Forbid-troves-from-accepting-equipped-items.patch
2013-05-26 22:34 blackcustard File Added: 0002-Make-note-of-the-items-paid-shown-to-enter-troves.patch
2013-05-26 22:37 blackcustard Note Edited: 0022673
2013-05-26 22:53 blackcustard Note Edited: 0022673
2013-05-26 22:55 blackcustard File Added: 0001-Forbid-troves-from-accepting-equipped-items.patchNEW
2013-05-26 22:55 blackcustard File Added: 0002-Make-note-of-the-items-paid-shown-to-enter-troves.patchNEW
2013-05-27 17:16 mumra File Deleted: 0001-Forbid-troves-from-accepting-equipped-items.patch
2013-05-27 17:16 mumra File Deleted: 0002-Make-note-of-the-items-paid-shown-to-enter-troves.patch
2013-05-27 17:17 mumra Note Added: 0022886
2013-05-27 17:37 blackcustard Note Edited: 0022673
2013-08-27 19:55 MarvinPA Issue Monitored: MarvinPA
2013-11-03 05:56 neil Relationship added related to 0007694
2014-03-27 05:24 MarvinPA Category Bug Report => Patches
2014-04-29 02:28 MarvinPA Note Added: 0025939
2014-04-29 02:28 MarvinPA Status new => resolved
2014-04-29 02:28 MarvinPA Fixed in Branch => 0.15 development branch
2014-04-29 02:28 MarvinPA Resolution open => done
2014-04-29 02:28 MarvinPA Assigned To => MarvinPA
2014-04-29 02:29 MarvinPA Issue End Monitor: MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker